View Full Version : Not attached to hub????

01-09-2007, 03:43 PM
Hi all-
OK, this one appeared out of nowhere. I'm using LW 7.5 (call me grandpa LOL), and everything was fine...until today.

In modeler, I tried to send an object to layout and got an error message:
"Error: Modeler is not attached to the hub." F12 doesn't work, and the upper right hand Switch/Synchronize/Send controls are greyed out.

This appeared out of nowhere. Was working fine yesterday. does anyone know why I'm no longer "attached to the hub?"
Any suggestions would be greatly appreciated.

01-09-2007, 04:06 PM
what happens if you reboot?

01-09-2007, 04:31 PM
Hi Bytehawk-
Thanks for the reply. I tried that earlier today, and just gave it a shot again.
This time, I opened LW first, then modeler, loaded my object...
same problem...."modeler is not attached to the hub."
????????? Too weird.

01-09-2007, 04:33 PM
I have 8.5 but I think the following would apply to 7.5.

If your os in windows, do you see the hub icon in the system tray (normally at the bottom right of screen) when modeler is running? Or, with modeler running, check the Windows Task Manager (ctrl-alt-del) and under the "Processes" tab do you see an Image Name "hub.exe"? If you see either of these, then the hub is at least running. If you don't see it, go to the lightwave program directory ( ie c:\program files\lightwave\programs\ ) and try starting the hub by double-clicking "hub.exe" and see if that helps.


01-09-2007, 04:41 PM
You can also try this... find the hub config file "LWHUB8.CFG" in my case and located at "c:\Documents and Settings\your-user-name\" and rename the file to say "LWHUB8CFG.bak" and then restart modeler and see if the hub is working.


01-09-2007, 04:42 PM
Hi Don-
Yes, the hub is running (just not behaving). Hub appears as it should when I open LW or modeler. Everything is fine until I try to send an object to layout.
(I'm running XP pro SP2, btw).
I would try reinstalling, but I know from experience that will cause dongle issues.

01-09-2007, 04:52 PM
A couple of things...
If you right-click on the hub, does it show layout and modeler under the "Launch" title? If not then it doesn't know where to find what's not listed.
If it does show them both, close modeler, open layout and press f12. If that doesn't work, let's move on to the rough stuff...

Find your version of LWHUBX.cfg, the X being your version. Open it in notepad for inspection; one or the other is listed, or should be based on what you've said so far. Duplicate that line with lightwave.exe/modeler.exe replacing, in the duplicate line, the other app that's missing.

One could also put other apps in here while one is mucking about...
That should get you up and going.

01-09-2007, 04:55 PM
You can also try this... find the hub config file "LWHUB8.CFG" in my case and located at "c:\Documents and Settings\your-user-name\" and rename the file to say "LWHUB8CFG.bak" and then restart modeler and see if the hub is working.


OK...will give that a shot and see what happens- thanks again!

01-09-2007, 05:23 PM
Below is what I've got. Naturally, they're both there :(
I'm going to try renaming it to .bak as per the other post and see if that suggestion works. (yes, I'm saving a copy of the original)
Will reboot now and see what happens!
Back online in a few....thanks for the help so far!

FileRequesterServer $Default
ColorPickerServer $Default
TimeOptionsIndex 0
SaveClientIndex 0
DialogCenter 720 459
WindowShape 10 570 374 300 171
ProcessName LWLayout C:\LightWave\programs\lightwav.exe "C:\Documents and Settings\Mike Pasternack" C:\Documents and Settings\Mike Pasternack
ProcessName LWModeler C:\LightWave\Programs\Modeler.exe "C:\Documents and Settings\Mike Pasternack" C:\Documents and Settings\Mike Pasternack
AppConfig FrameSliderLabel 0

01-09-2007, 06:11 PM
Well, I tried both fixes, and still am getting the error message.
I've uploaded a screen shot of the hub...perhaps I'm missing something obvious?

thanks again everybody,

I don't see the pic in the message preview (I'm new to this forum, so the link is below...sorry!)


01-09-2007, 06:44 PM

Sorry nothing worked - what a bummer :(

The only other thing that I can think of is to hide the main lw config files by renaming them as before and letting lw recreate them. If you want to try, rename the LWMx.cfg, LWHUBx.cfg and LWx.cfg all to " .bak". When you restart modeler and lightwave, all three files will be recreated.


[edit] ok, one more thought - is it possible that there is more than one hub.cfg on your computer? You may want to do a search to be sure.

01-09-2007, 07:04 PM
Hey don-
thanks a bunch for your help....I'll try the rename/recreate as you suggest.
* there's only one hub.cfg on the computer...I did a full search before I started playing around with it.
I'll post later and let you know if any success.
Much appreciated,

01-10-2007, 07:52 AM
Hey Don-
(and the rest of you all...many thanks for all your help). This is the first forum I've posted as a newbie where everyone was so helpful!
At midnight, having tried just about everything and then some, I said to myself "OK- I've tried everything logical....what could possibly have caused this overnight?"
And then it hit me....how do you mess up a pc in 3 letters??? AOL.
Yep...seems the firewall in the aol "security center" Had decided all of a sudden that "hub" was a potentially dangerous program, and blocked it.
I shut off the AOL and sure enough...hit F12 and all worked fine.
So I'm up and running again, it was something stupid....and again-
Many thanks to everyone who tried to help with this issue!

01-10-2007, 01:53 PM
Glad to hear you found you problem :thumbsup: