PDA

View Full Version : Black screen render when adding shadows



Aubade
12-18-2006, 02:48 PM
Sorry to bother you guys again..

I've been following our esteemed SplineGod's Apple tutorial and when I add ray-traced shadows all I get is a black screen.

The only difference between the 2 attached screenshots is that I activated ray-traced shadows for the 2nd one.

umm.. could someone tell me what I'm doing wrong please.. ?

thanks

Silkrooster
12-18-2006, 04:58 PM
2 things come to mind
1) you have an object blocking the light
2) the light is not point at the object
Silk

gerry_g
12-18-2006, 05:19 PM
Yeah it looks like you have some kind of backdrop or mesh and if your light source is outside of this as soon as you turn on shadows the light will be excluded. If this is what it is select that object, go to the 'Object Info' panel and uncheck 'Cast Shadow' from its 'Render Properties' tab, this should let the light back in.

Aubade
12-18-2006, 06:10 PM
thanks for the replies guys

I would've thought the render with no shadows would've shown anything in the way, but I've made sure both camera and light have a clear field of vision(as you can see from the screenshot) .. and the result is the same, again as you can see.

I'm completely mystified.. anyone else have an idea?

Aubade
12-18-2006, 06:21 PM
I tried adding another light (point) above in front and to the right of the apple in the scene.. same result.. black screen.

Most ununderstandable :o

gerry_g
12-18-2006, 06:35 PM
Do you have auto key turned on( center screen under the time line), it doesn't look like it from what I can see in the screen grab, if it is not both the light and camera will jump to zero, zero, zero, x,y,z every time you hit F9, meaning thatthe camera renders from that point and not where you set it.

Silkrooster
12-18-2006, 06:54 PM
Try this, change your grid to 1 meter and move your camera and light back to the same location(remember to set key frame with enter key if auto keyframe is turned off). [ and ] keys change the grid. I have a feeling your outside object is interfering.
Silk

SplineGod
12-18-2006, 09:44 PM
zip up your files and post them up. :)

Aubade
12-19-2006, 09:18 AM
I had noticed the movement of lights and cameras if the scene wasn't keyframed and it definitely was. Tried again today with the same result.

Thanks Larry :thumbsup: Files attached.

SplineGod
12-19-2006, 09:37 AM
The problem is that you have polygon on top of the tray the apple is sitting in. Remove that and all is well :)

Aubade
12-19-2006, 11:40 AM
DOH! *blushes redder than a-a- umm apple* Guess I'm showing a little green too....


hehe.. still not sure why that wouldn't show on a render with no shadows but wOOt! finally sorted. Thank you very much and...

MERRY CHRISTMAS ! :beerchug: :D

SplineGod
12-19-2006, 10:32 PM
cheers! :)