PDA

View Full Version : Mesh´ed render



Darth Buss
12-01-2006, 05:59 AM
Hi.

I made a big square, subdivided it and subpatched it and pulled some points up to make a snow-landscape (well, i needed to make one ok?).
I made the surface smoothed, i set the anti-alias to medium, i have a single arealight in the scene, i set the object to "subpatch last", in "Render options" i set the shadows to "Ray Traced" and the render mode to "realistic".

My problem is this: When i do a render, the geometry (the snowlandscape) comes up "meshed" in the shadows. By Meshed i mean that the outlines of the mesh grid is showing (see attached jpeg).

I need urgent help as i have a deadline on the movie i am making and this shadow problem makes the whole thing really ugly

Sensei
12-01-2006, 06:41 AM
Are you sure you don't have double sided polygons and all points are merged and polygons unified and not duplicated in the same places?

Cougar12dk
12-01-2006, 07:05 AM
Looks like what Sensei pointed out. Try opening the poly statistics panel (w-key, while in poly selection mode) and look for anything unusual in there. There shouldn't be any 1 or 4> vertices. If there are you should delete them.

voriax
12-01-2006, 08:05 AM
Just looks like a basic shading problem to me.. no shadows switched on, so you get a very opengl-looking render..
Only suggestion I could make would be to set up your lighting and switch on shadows and maybe increase the mesh poly count..

Darth Buss
12-01-2006, 08:07 AM
Thanks for your replys guys.

I have no 1 or >4 plys there. The polys are not doublesided and the points are not merged.
The strange thing is that i had the problem at work and just made a quik simular scene from sqratch, at home and have the same problem.
I really just made the box, subdivided it with the arrowkeys and pulled some points to make the landscape.
Why is it just the shadows that have the problem? Am i nuts? I really cant figure out what i am doing wrong. Is there anything i should define besides the Ray Traced shadows, about the shadows or the geometry?

Darth Buss
12-01-2006, 08:10 AM
Thanks voirax.

How do i switch on shadows? Did i not do that when i switched on Ray Traced in the ligth properties dialogbox? And how do i increase the mesh polycount?

prospector
12-01-2006, 08:57 AM
well here's what I get setting render levels (in object properties).

prospector
12-01-2006, 09:00 AM
Tho I don't remember getting shadows in any LW before this (it usually smoothed out pretty good).
Probably shouldn't be there, but could have something to do with the new rendering code.

Having to up the poly count seems unproductive in rendering times.

Extent
12-01-2006, 01:16 PM
You sure that you don't have any surface shaders on that? I know that the doublesided surface option gives me all kinds of problems with subpatched surfaces, but that effect is slightly different than what I see there.

shrox
12-01-2006, 01:27 PM
What is your smoothing threshold set to? Try it about 40 degrees or so.

Darth Buss
12-01-2006, 02:37 PM
No surfaceshaders. The surface is the default, smoothed with an angle of 40%. The light is a arealight with raytraced shadows. The antialias is set to Medium.
Thats about it!
I still get the result shown in the thumb.
I am running out of ideas.

Extent
12-01-2006, 03:50 PM
now that looks like the doublesided problem I'm familiar with, if the surface setting is fully default are you sure that the geometry is clean?

If you increase the subpatch level the artifacts will get smaller, but not go away.

Extent
12-01-2006, 04:29 PM
Ok I'ld like to amend that a bit, just did some tests, results are below.

lots
12-01-2006, 05:48 PM
the mesh density doesn't seem high enough to me... hence the jagged edges at sharp peaks. There are multiple ways to combat this, the easiest being setting the render level of the object to something like 10 or 15...

Oddly, it also looks like some sort of an attempt to use kapa (i've produced polys that look similar messing around with the kapa node..)

toby
12-01-2006, 06:27 PM
well here's what I get setting render levels (in object properties).
What he means is, go to object properties, geometry tab, and turn up the subdivision level until it smooths out, because you're never going to get smooth results with polygons that big.

Darth Buss
12-03-2006, 11:59 AM
Thanks a lot guys. Its great that you take the time and effort to help a newbie on his way. I appreciate it.

Darth Buss
12-03-2006, 12:14 PM
Thanks a lot guys. It worked like a charm. My geometry was made up from huge polys and the subpatch level increase did the trick. Nice of you all to help me out.