PDA

View Full Version : Hypervoxels - Help!



ben martin
11-28-2006, 09:45 AM
Hi all,

I'm rendering this scene to a short-story-movie. No profit on this one except the fun!
I'm using hypervoxels (Volume) to simulate space-gas-nebula.
It's imperative that the camera can dive inside the hypervoxel volume clouds.

The Hypervoxels "Near clip distance" are set to default (1m) but beside that I'm using a null ahead parented to camera (distance up to 10m) to Dissolve the hypervoxels using a "Dissolve Texture Gradient"

Input parameter=Distance to object
Object=Null
Gradiant Scale= 10m
0m=Value 100%
5m=Value 0%
10m=Value 0%

I'm setting this Dissolve Gradient as an assurance method to dissolved the hypervoxel before the camera reach that clip distance!
Despite all the tricks the problem remains.
See the attached image.

Anyone knows a better solution to solve this one?

Many thanks in advance!

ben martin
12-10-2006, 12:45 PM
Ok, since no one was able to help me to find a solution to this one I’ve found the answer myself doing tests over tests!

To the ones that can find the same problem, the solution has nothing to do with “clip distance” what so ever, instead it’s related with the Hypervoxel “Render Quality” parameter.

Conclusion:
If you plan to use Hypervoxels to simulate nebulas, gas and related FX be very careful using this very important parameter.

I was using “Medium” quality and that created all reported clip errors!
“Very Low” is the best set to achieve nebula, gas camera dive in the FX.
(See attach image)

Hope this can help.

toby
12-11-2006, 12:11 AM
By default, interpolation between keys in a Gradient is set to Spline, and it smooths just like animation and spline curves. So if you have two keys set to 0 and a third set to 10m, you'll get values in the negatives, and this could easily create an artifact like the one you're getting.

The first thing I would do is verify whether that is actually causing your problem by seting the keys to Linear. If that fixes it, but looks funky because it needs to be smooth, you'll have to raise the value of the center key in order to keep the curve from dipping below 0.

ben martin
12-11-2006, 03:37 AM
Thanks about the tip Toby but I'm not using the gradient "null" anymore.
I solved the problem by changing the Hypervoxels "Render Quality".

Many thanks anyway!

Cheers!