PDA

View Full Version : plugin blues



chab00m
11-21-2006, 10:24 AM
Just added some new plugins. Next, I edit layout so that I can create buttons of my new plugins then save the mylayout.cfg file, but if I were to close modeler then reopen it, the buttons I just added are gone. Oh, by the way, do I need to run LSC files with Lscript/RT, compile them, before making buttons or does it matter?

evenflcw
11-21-2006, 05:08 PM
.p, .ls, .lsc makes no different. You add/install them the same way... just Add Plugin.

About menu/hotkeys not being saved. The .cfg file you save isn't whats being read everytime you open up LW. It's the LWMx.cfg and LWx.cfg (x being either 3,8,9 depending on what version your using) in your 'Documents and Settings' folder which are read. I can't say why your menus don't stick, but some things to check for:

1. When you altered the menus, did you quit properly? Interface edits are saved at exit, so if you crashed before or you encountered som other anomaly upon exit then you would loose the changes. I think maybe LW9 works differently (finally!).
2. In order for settings to be saved naturally the LWx.cfg LWMx.cfg mustn't be write protected. So check for that aswell.
3. Some people setup the LW shortcuts to point to a non-default folder in which the configs should be found. If the address is wrong in some way LW might not be able to find the configs.

EDIT: I remember reading about other people having similar issues so you might try searching the forums. Always nice to know you're not alone aswell :)