PDA

View Full Version : One for the eggheads



CAClark
11-12-2006, 03:55 AM
In XP Home, Layout always starts with affinity only to CPU0. Every time I have to reset it to be associated to CPU1 also.

However, in Vista, it always has it's affinity set to both CPU's from the get go.

So my question. how can I get XP Home to remember that Layout should be tied to both cores instead of just 0?

Cheers!

Extent
11-12-2006, 04:31 AM
well you can use Imagecfg.exe from the Windows 2000 Server Resource Kit to permanently set the affinity mask for an executable. I can't say exactly why Home wouldn't set it to all automatically, I thought the processor limit was 2 (and if it was I'ld think it wouldn't let you set the affinity manually either)

CAClark
11-13-2006, 09:27 AM
Anyone else?

Bog
11-13-2006, 09:58 AM
I'm awfully tempted to be glib and say "Upgrade to XP Pro" - I've got a sneaking suspicion that the auto-affinity setting is omitted from that version of the OS.

Sorry that's not a solution, but I *think* that's one of the little gaps in XP Home.

CAClark
11-14-2006, 06:39 AM
That could be it actually, I hadn't thought of that, as Vista is the Ultimate version.

Cheers!

Verlon
11-14-2006, 07:39 AM
I thought XP home didn't play nice with multiple CPU cores. I recall that being one of the differences between the two versions ( and the reason I went pro back then).

Has this changed?

Bytehawk
11-14-2006, 08:28 AM
correct, Verlon

I had to buy pro because of that for my xeon system.