PDA

View Full Version : Caustics



kiwi dave
06-13-2003, 04:30 AM
I am slowly but surely expanding my knowledge of Lightwave but I keep hitting seemingly simple problems that I can't seem to figure out.

The latest one is caustics.

I have three books at home relating to Lightwave, and all mention caustics as though it were as simple as turning on the caustics option. But it doesn't seem to be that way.

To experiment I have created a glass globe (with refraction) on a blue surface. I turn on caustics, have my light set to affect caustics, and turn on caustics in the render options panel.

What have I missed? :confused:

Any help always greatly appreciated.

Cheers

Dave

Mylenium
06-13-2003, 05:05 AM
Have ypou turned on raytraced refraction and reflections?

Mylenium

kiwi dave
06-13-2003, 05:17 AM
Yes I've got all of the ray trace options selected.

Attached is a render of my test. I am using an area light (but don't know if that is the right kind of light to use?)

Dave

Exper
06-13-2003, 05:38 AM
kiwi dave...
We know they work in a little strange way! ;)
Increase "Intensity" (normally I use valueas from 1000% to 1500%) and eventually "Accuracy";
activate "Ray Trace Shadows" for more realistic effects!

Bye.

kiwi dave
06-13-2003, 06:05 AM
Thanks for the tips.

I've continued playing and found that caustics seems to work with a distant light, but not the others.

Is this correct?

Dave

caesar
06-13-2003, 06:47 AM
Kiwi dave, hereīs the solution-

in your lights props, u have to select the option for affecting caustics (i donīt remenber the tab exactly, but itīs near the affect ray trace, shadow, etc boxes). If it isnīt enabled, the global ilum prop will have no light for the effect!
Post the picture for us!;)

Exper
06-13-2003, 08:41 AM
kiwi dave...
set "Affect Caustics" to ON in "Basic" tab of light properties; all lights types but Distant can produce caustics.

Bye.

kiwi dave
06-13-2003, 09:25 AM
Now I'm really confused.

The only light that seems to work for me is a distant light, yet you think that a distant light is the only one that won't work???!

Here is a render with a distant light.

Dave

Exper
06-13-2003, 10:00 AM
It seems really strange to me!
What version of LW are you using (a pre 7.0 one)?

Bye.

kiwi dave
06-13-2003, 10:27 AM
I'm using Lightwave 7.5 on mac OS X.

Any clues??

Dave

Exper
06-13-2003, 10:43 AM
I'm using LW 7.5 on WinXP and Caustics are available for all but Distant lights. :(

Bye.

toby
06-13-2003, 03:34 PM
I played with caustics and had similar problems, it seems that caustics is one of the few things where size and distance are not relative ( 1 meter sphere that's two meters away from the light give totally different results than a 10m sphere that's 20m away from the light) - that's why dist light doesn't work - ( your render doesn't look like caustics - the option is greyed out on my mac)

load the caustics example scene from your LW content directory for a starting point - I just threw some objects into a scene to test, I guess my light was too close or something, I had to turn the caustics intensity down to 1% to keep from blowing out the whole scene - it's really touchy

rob davis
06-13-2003, 03:35 PM
Can you post your objects/scene so we can take a look at them? That should help us solve your problem quick-like! :)

Oh, and turn your refraction down a bit... It looks like it's waaay too high. That might be shooting your caustic reflections all over the place... Set your sphere's reflection to about 1.333 (that's good for glass, if I remember right), copy/paste your sphere into the exact same spot, flip the normals and add an "air" texture to it (100% transparent, no spec and a refraction to 1.003) to compensate for the light bending a little due to the air.

See what you get from that.

hcoat
06-14-2003, 01:12 AM
The straight line of the floor through the middle of the globe and the lack of the floor color around the top edge of the globe tells me that the refraction index is set at the default ?1?. The dark shadow will result from using the default setting of caustics and refraction together. Turning the setting up for both caustics and refraction should give you better results.
The last pic of the distant light looks as though the edge transparency shader is used, with caustics on, this shader will only show up when using a distant light, that is because the effect of this shader are basically cancelled out when using caustics.

Good Luck.

caesar
06-16-2003, 05:57 AM
Just put a spotlight for the caustics test and post it!;)

kiwi dave
06-16-2003, 06:59 AM
Thanks for all the tips guys and girls. I followed Toby's advice and started with the caustics scene in Lightwave and took it from there. Everything is looking good now, and it solves the problem for this project I am working on.

Will keep experimenting later when I have more time.

Cheers everyone

Dave