PDA

View Full Version : Disabling deformation on certain objects?



duke
11-06-2006, 12:10 AM
Is it possible to do this? It slows down the computer noticeably when deformations are active and all i really want to do is work on a single character.

Dodgy
11-06-2006, 02:47 AM
Setup>Bones>EnableDeform

This works with bones and displacements.

SplineGod
11-06-2006, 02:56 AM
You cant. Even enable/disable deformations doesnt work right. Theres a few options for dealing with lots of deformations.
Reduce the bounding box threshold
Reduce the subpatch level to 0 on anything youre not directly animating ATM.
Use proxy objects or standin characters when animating. You really dont want to mix animation and deformations at the same time. Heres an example showing a rig that can switch between a lowrez proxy for animation and a high rez character for checking deformations - http://www.3dtrainingonline.com/examples/char_rig_demo.zip.
You can also bake (mdscan) defomations for characters that are already animated. After doing this turn off the bones for that character. It will speed things up.

duke
11-07-2006, 05:23 AM
Ok thanks for the replies :)

toonafish
11-07-2006, 05:56 AM
you also could temporary replace an object with a Null so there's nothing to deform.

If you're using bones and weightmaps you might want to collapse your object into a single point with all the weightmaps so Layout doesn't forget what bone should use which weightmap.

duke
11-07-2006, 07:36 PM
I was sure there was a plugin or script or something that automatically swapped out an object with another at rendertime.

duke
11-07-2006, 07:42 PM
There's this thing: http://www.interialabs.de/lw/lscript/index.html but theres no documentation as to how to use it.

toonafish
11-08-2006, 12:11 AM
maybe "Object Version" is what you're looking for ?

http://earthwormjim.free.fr/