PDA

View Full Version : Lightwave 9 Open GL problem



Kaiten
11-02-2006, 03:04 PM
Hi Ive just upgraded to 9 from 8.5. Im currently setting up a typical radiosity scene with a skydome and ground layer.

Ive gone into the light properties window and turned off affect diffuse and affect specular. Ive left Affect open GL on as i use this light to see the models in the layout screen but not have the light affect the rendered shot, however when affect diffuse is switched off the "lights go out in the layout screen" this didnt happen in 8.5...

Does anyone have an idea to whats going on?

Cheers

Chris

ramccombe
11-04-2006, 09:47 AM
I have the same problem here with all light types . :grumpy:

PowerBook, 9, 10.3.9

Chilton
11-04-2006, 09:54 AM
Hi,

I have not seen this myself, so my first assumption is that you're just shutting your eyes after you turn off affect diffuse. However, I believe it would be then difficult to find Safari or FireFox, and then post this question, without opening your eyes.

Therefore, it is possible you have found a bug. Please post system specs, and I'll look into it asap.

-Chilton

ramccombe
11-04-2006, 10:12 AM
Now that's funny. You're correct I did figure out it was better to keep my eyes open but the results are still the same.

1 GHz PowerBook, 10.3.9 and Lightwave 9 :help:

Chilton
11-04-2006, 10:21 AM
Kaiten,

What are the specs on your system?

-Chilton

ramccombe
11-04-2006, 10:31 AM
I thought I had it in the post short ram spec. 1 GHz PowerBook, 10.3.9, 1 gig ram, LightWave 9

Chilton
11-04-2006, 10:39 AM
Hi Ramccombe,

I am actually not ignoring you, just looking for more info. I want to know if Kaiten has the same specs as you. If that's the case, I can narrow down what I'll need to test, to replicate the results.

For example, I have a 1.6Ghz PowerBook and a 2.1Ghz MBP here, both running Tiger. If Kaiten's specs are G5, with Tiger, then I have a wider area to search. I could probably start testing this now, as soon as ****secret feature description removed**** is done. If his specs are 867Ghz PowerBook, and Tiger, then I should go try to find a machine in the spec range between yours and his, and test LW. If he has exactly the same setup you have, I'll need to replicate that setup fairly closely, before testing.

-Chilton

Kaiten
11-04-2006, 12:03 PM
Hi Chilton

Im running:

Power Mac G5
Dual 2 GHz
3.5 GB RAM
ATI Radeon 9800 128mb

OSX 10.3.9

Lightwave 9

Hope theres enough there. Thanks for the help...

p.s if this is a bug do I get a free t-shirt LOL :thumbsup:

Chilton
11-04-2006, 12:10 PM
Hi Chilton

Im running:

Power Mac G5
Dual 2 GHz
3.5 GB RAM
ATI Radeon 9800 128mb

This rules out the hardware.



OSX 10.3.9

This is interesting.


Hope theres enough there. Thanks for the help... No problem.


p.s if this is a bug do I get a free t-shirt LOL :thumbsup:

We'll see. I'll go rummage through my closet in a bit.

-Chilton

ramccombe
11-04-2006, 12:38 PM
Sorry Chilton, I assumed the email I received pertained to me only and not the whole thread. Hope you have enough info to verify if it's a problem and fix as necessary. Thanx.:)

Chilton
11-04-2006, 12:41 PM
No problem. I think this is enough for me to go on. It *may* be some odd OS level bug though, which you'll need to upgrade to Tiger to fix. I'll let you know.

BTW, Tiger is generally faster than Panther on both of those machines, or at least that's been my experience.

-Chilton

Kaiten
11-04-2006, 01:13 PM
Thanks Chilton ... might wait for Leopard to be released before upgrading

:thumbsup:

toby
11-05-2006, 11:26 PM
Whoa! Hit the brakes! screech!
We were told this was a new workflow - and no I'm not kidding - this happens to me too - was told that unchecking the light in the scene editor was the new way to do what you need.

That said, I hate the 'new way' of making a light only affect OpenGL. It renders the button useless, so why is it still there? And it requires you to have the scene editor open.

Whether it's a bug or a feature, I'd love it if it were annihilated.

Castius
11-06-2006, 12:01 AM
affect diffuse and affect specular are now actually useful to openGL display. Making openGL light match close to the rendered results.

So you now can actually have a spec only openGL light or a diffuse only light.

Yes i agree that having the scene editor open to control this is a little extra work for users that don't work with a scene editor open all time time. But IMO it's worth the extra benefits. They just need to add a on off switch to the light properties panel.

toby
11-06-2006, 01:08 AM
Holy ***** he's right!

Kaiten
11-07-2006, 03:56 PM
Thanks guys the work around is exactly what I need... :yoda:

Scazzino
11-07-2006, 06:37 PM
Ive gone into the light properties window and turned off affect diffuse and affect specular. Ive left Affect open GL on as i use this light to see the models in the layout screen but not have the light affect the rendered shot, however when affect diffuse is switched off the "lights go out in the layout screen" this didnt happen in 8.5...

Does anyone have an idea to whats going on?

Yes, this isn't a bug, but a change in LW9.

As mentioned previously, to do what you want you need to turn on affect diffuse (and/or specular if desired) as well as affect OpenGL. Then turn OFF the active checkmark for the light in the scene editor. This will let the light work in the OpenGL viewport without affecting the render.

The reason affect OpenGL is there is that if you have a scene with many lights you can set which ones will affect the OpenGL viewport and which will not affect it. To control which will and won't render you now use the "active" checkmark in the scene editor.

It might be nice if they could add a switch on the Light Properties for "affect render" (active) as well so it could be turned on/off from either the scene editor or the light properties...

ramccombe
11-07-2006, 07:54 PM
Says it all, Thanx. :)