PDA

View Full Version : Can't Flag Shadow-Mapped Shadows?



Giacomo99
10-22-2006, 04:20 PM
Hello-

It seems that un-checking "Cast Shadow" (either in the Scene Editor or Object Properties window) is ONLY effective with raytraced shadows--shadow maps cast shadows no matter what.

Is this a bug? Has it been an issue for a long time? Is there a way around it? Please advise.

Sekhar
10-22-2006, 05:55 PM
This is correct behavior. If you want a specific object to not cast shadow, one workaround I can think of is to exclude it from the shadow casting light and to add a duplicate light (with shadows off) linked only to that object.

Exception
10-22-2006, 06:23 PM
For shadow maps you have to uncheck cast shadows AND self shadows.