PDA

View Full Version : Big Problems with Radiosity



jonerwin
06-11-2003, 07:21 PM
I'm doing a scene with a building and the geometry is fairly complex. When I render a still frame it looks great, but when I render an animation it seems to calculate the radiosity differently for each frame, resulting in a "blotching" effect. Can someone help me!?

Radiosity settings

Interpolated

intensity 300%
Rays per 5 * 15
Tolerance .232
min eval 200 mm

Anti-aliasing Low
Motion Blur normal

Danner
06-11-2003, 11:33 PM
do you have -shading noise reduction- on?

da_duke
06-12-2003, 01:24 AM
the problem is 'interpolated radiosity', if you don't enable the option 'cache' you will get different results for each frame. unfortunately, the render time will explode (often, not every time) if you use this option. it is a bug that will increase the render time for each frame drastically. increasing the settings for interpolated radiosity may help or switching to monte carlo but this will also affect your render times.

Gouac
06-12-2003, 07:14 AM
If the lighting doesn't change (fixed lights with fixed intensity), you should either try to bake it or just cache radiosity. The result should be the same. Baking is a bit more complex to set up, but it's also more reliable. Plus you can edit your texture in photoshop for bluring or whatever.
If the lighting changes, set to montecarlo and come back in a few years.

jonerwin
06-12-2003, 08:50 AM
O.K. I spent a day setting up the UV maps to bake the surfaces. Never baked before, what settings should I use.
Monte Carlo or Interpolated
What resolution should they be: 512
Should they be HDR

And can someone explain to my why interpolated radiosity comes up with different results per frame, this really bugs me!

jonerwin
06-12-2003, 09:08 AM
This is the render right now

jonerwin
06-12-2003, 01:48 PM
If I turn on cache radiosity does this mean I cant use my other machines to render, b/c it's doing the same thing.

btw Each frame is about 30 min w/ cache on. Anti-aliasing enhance Low, Motion blur - Dither, is that what I should expect.

Mattoo
06-13-2003, 01:52 PM
That looks really nice! Top stuff.

Yes it's not a good idea to have cache radiosity on if you're rendering on multiple machines. I've never tried it myself but I'm led to believe that the different machines will calculate slightly differently and you'll get a flicker as the cache is not saved with the scene or anything.

I've tried baking a few times and have never had much success. On anything particularly complicated it just grinds to a hault when baking the solution. And I never found the default 512 image size large enough - but anything larger dramatically increases baking time.

You might want to turn ON Limit Dynamic Range (in the Effects panel) to get rid of the jaggies on the floor where the light is bleaching it out.

That render time sounds about right - if you turn off raytrace reflections it'll probably go loads faster. You could then do a second pass with no radiosity, save out the reflections buffer and overlay that with the full render. Will be loads faster but is a bit of a pain.