PDA

View Full Version : Share .lws Mac - PC



eFFeFFe
10-10-2006, 09:33 AM
Hi ... We have some mac's and pc's in our lightwave pipeline and we always have trouble when a lw scene made on a mac is being opened on a pc. Objects / object layers / images cannot be found anymore, and every object / object layer / image has to be replaced again (a known problem, I guess). For some interior scenes, a lot of work ! ... We tried to fix some of it by editing the .lws file and find / replacing the paths, this works for the objects and object layers, but not for the images linked to those objects (images don't have appear to not have a path reference in the .lws file). We also already tried to correct the content directory inside Lightwave (8.5 and 9) with the new content path options, but none worked ... Is there some solution or logic, workaround for this ? Could there be a problem with the Mac (OsX) file path with ":" seperators and Windows (XP) with "/" seperators ?

tnx & greetz,
ef.

JML
10-10-2006, 09:59 AM
I don't have this problem,

it's important to have the content correctly setup.

if the content is setup on windows like this :
xx.xx.xx.xxx\lw_p

and you put all your lw files inside like that for example:
xx.xx.xx.xxx\lw_p\Project_1450_LW\*.*

then on the mac, make sure the content is set to
the same "xx.xx.xx.xxx\lw_p"

and then you will be able to load and save scenes from osx or windows
(you won't have to tell where to find the images or objects, it will know)

toby
10-11-2006, 12:41 AM
This is an issue sometimes, and I've seen it happen both ways, but more often from Mac to PC. The thing to do is open the scene file in BBedit ( on the Mac, there's a free version on the web ) and re-save it with DOS line breaks. Go to "save as", find the Options button, then find Line Breaks.

jeremyhardin
10-11-2006, 01:21 AM
Yep. These two suggestions are almost 100% sure to be the solution. Every time I've had the problem spoken of, it's come down to assets outside the content directory structure, and/or line breaks problems. resovle those, and you have total compatability.

eFFeFFe
10-11-2006, 04:11 AM
Hej ! Thanks for the tips ... 'm gonna try those out and see if I can fix it that way ... The problems occur mostly when opening mac scenes on a pc ... no problems from pc to mac ...


grtzzz,
ef.

eFFeFFe
10-12-2006, 07:06 AM
Setting the content directories correctly fixed the sharing issues ... The problem, I think, was that we set our contect directory to the root of a workstation (so that content always could be found), on a mac this would be "HD Username", on a pc this would be "c:" (or "c:\"). Paths to objects inside the .lws file on mac then could be "HD Username:workfolder/project_001/objects/object_001.lwo". I think a pc cannot read this path because a pc should expect a path to be "HD Username:\...". By not adding the root directory to the path, no ":" characters are added to the path, and it looks like lightwave maybe had some issues with that ...


grtzz,
ef.