PDA

View Full Version : Omega Trouble with Polygon Side Node



Earl
10-05-2006, 01:42 PM
I'm attempting to use the node editor to apply an Omega SSS shader to an object, also using the Polygon Side option in the Spot info node to simulate the "air polys". For some reason the polygons on my objects are showing up individually (the edges of the polys are visible). It seems to be related to the Double Sided flag in the surface properties.

My settings are below, and I'm attaching the object/scene files. If anyone can help me eliminate the edges on the render I would really appreciate it. Thanks! :D

Settings:
- Omega SSS node (I've tried it with raytracing enabled and disabled)
- Perspective Camera (I've also tried the classic camera)
- Raytracing of Shadows, Refractions, Reflections and Transparency all enabled (I've tried multiple combinations of these as well)
- Doubled Sided (checked in the surface properties - necessary for this setup)
- One single distant light, with no ambient light
- Threads set to 2 but I've tried it at one (using a Core 2 Duo processor)

Again, thanks for any help with this!

Earl
10-05-2006, 02:59 PM
Well, here's another example. This time there is no Polygon Side node used. This is simply Omega with a set of air polys. The polygon edges are much fainter, but clearly present. It's funny, I didn't notice these before. Is this a known bug with Omega, and I just haven't seen it on the forums yet?

connerh
10-06-2006, 03:14 PM
this happens when you have the depth set too shallow for the number of polys present. Usually subdividing further will fix it.

Earl
10-06-2006, 08:29 PM
Thanks for the help connerh. Unfortunately it didn't seem to solve my problem. Instead the polygon edge lines just got smaller, in both the polygon side node instance and the air polys test. I just can't seem to get Omega to produce a result without those outlines.

I find that if I turn off ray trace shadows when using the polygon side node then the edges disappear, but then the SSS doesn't look very good. In the case of using air polys, turning off ray traced shadows does not clear the problem up.

Any other ideas? Tess, I don't suppose you'll pop into the thread and tell me what I'm doing wrong. :hey:

moc
10-07-2006, 12:20 AM
Thanks for the help connerh. Unfortunately it didn't seem to solve my problem. Instead the polygon edge lines just got smaller, in both the polygon side node instance and the air polys test. I just can't seem to get Omega to produce a result without those outlines.

I find that if I turn off ray trace shadows when using the polygon side node then the edges disappear, but then the SSS doesn't look very good. In the case of using air polys, turning off ray traced shadows does not clear the problem up.

Any other ideas? Tess, I don't suppose you'll pop into the thread and tell me what I'm doing wrong. :hey:


yep...I face the same situation with you....

serge
10-08-2006, 08:15 AM
Edit: deleted. I wasn't making sense...

Medi8or
10-08-2006, 01:03 PM
In your first post, I think one problem is in your nodetree. Try dropping the refractions node, and instead use an Invert node between Polygon Side and Transparency.
It doesn't remove the problem, but the lines are much fainter..

Earl
10-08-2006, 10:29 PM
Thanks Medi8or! That helps out tremendously. Funny, Tess said in another thread than the Refraction node automatically sets a surface to 100% transparent. But apparently it doesn't. This invert node makes the surface look much better.

Here's hoping they put some major work into Omega! I really like it as a shader, but it needs to be faster and less finicky.


Note:
The Refraction nodes set the surface transparency to 100%. Only when they
are connected to the Refraction Shading input does the Transparency percentage
in the Surface Editor scale the value. This is true for both Refraction Shading
(Transparency) and Reflection Shading (Reflection) as stated in the manual.