PDA

View Full Version : Multiple Displacements on single object - how?



JGary
09-28-2006, 11:43 AM
I'm trying to setup a single mesh to use 4 displacement maps using the displacement node. Each displacement map has it's own set of uv's. I tried to modify the node setup I use for one displacement map using the add4 node followed by the vector scale set to 25% to get the four images but this is giving me unexpected results. Here's some images showing my node setup as well as the results I'm getting.

37290

37291

Any help appreciated,
Jgary

JGary
09-28-2006, 03:22 PM
Ok, I made another image that more clearly shows the problem I'm having. I put a different color on each surface that has it's own displacement map. There's a shot of what my node setup looks like and 4 images, showing what the mesh looks like as each map is added. The head is the first map and looks fine when it's the only map. When I add the torso map both maps looks ok except for the polys that border the two maps at the neck. It looks like that area is being displaced by both maps. When I add the arm/leg map it gets a little weird. The arm/leg map looks fine, but now the head and torso has bloated itself up. And finally, when I add the hand map, it's bloated as well. I'm sure I have my displacement node setup wrong, but have no clue what needs to be changed.
37294

JGary
09-28-2006, 03:51 PM
I realized I have this posted in the wrong section and made a thread in the support area. How do I delete this thread?