PDA

View Full Version : Save Me



whodini
09-18-2006, 02:45 PM
I have been using LW9 since it came out and still have one major issue. I can't save in HDR formats. I don't think I am doing anything wrong as I can save HDR tiffs and radiance formats in 8.5 without any problems. I have tried rendering to file... nothing... it doesn't save anything. I have even tried saving from file viewer FP and nothing.

Non HDR formats save fine. If anyone knows a solution to this... please:help: !

P.S. I have problems with crashing whenever trying to preview an HDR image in modeler or layout. I can only see the mapped image in surface editor. This is a new problem in 9 too. It is probably related to the first problem.

Darth Mole
09-18-2006, 03:54 PM
It's a bug. Should be solved soon enough, I guess.

Weepul
09-18-2006, 07:03 PM
In the meantime save as .flx, open that and resave as .hdr from an older version of LW if you can. :(

jeremyhardin
09-18-2006, 07:09 PM
i thought cineon worked despite the others being broken?? can't test it right now though. but weepul makes a good suggestion.

Scazzino
09-18-2006, 07:15 PM
i thought cineon worked despite the others being broken?? can't test it right now though. but weepul makes a good suggestion.

Yes Cineon works, I've been using it all along...

Weepul
09-18-2006, 07:22 PM
I thought Cineon had a lower bit depth than Radiance (.hdr)?

toby
09-19-2006, 01:18 AM
Cineon is 10bpc, right?

I was going to recommend LightWolf's EXR plugin:
http://www.db-w.com/index.php?option=content&task=view&id=81

But that doesn't work in [9] either, I just tried it. I remembered playing with the 'Logluv' .tif format a few years ago, 96 bit and a small file size, so I tried that, it failed too. That's one bad bug :devil:

FLX works, but d*mn, it's a big file! Just tried the EXR saver in [8], it works, and the file is 1/3 the size -

whodini
09-19-2006, 07:58 AM
In the meantime save as .flx, open that and resave as .hdr from an older version of LW if you can. :(

Interesting idea... I will give it a try tonight. I will try cineon too!

Thanks for all of the feedback! There is a strange comfort in knowing that I am not the only one with this problem.

Cheers

jeremyhardin
09-19-2006, 08:06 AM
...I was going to recommend LightWolf's EXR plugin:
http://www.db-w.com/index.php?option=content&task=view&id=81

But that doesn't work in [9] either, I just tried it....

FWIW, the commercial version of it includes a layered saver (similiar but far superior to the PSD saver) which does work with LW9 on mac. works very well actually. as to why the plain saver doesn't work, I don't know but I can confirm it and am checking it out.

Lightwolf
09-19-2006, 09:03 AM
FWIW, the commercial version of it includes a layered saver (similiar but far superior to the PSD saver) which does work with LW9 on mac. works very well actually. as to why the plain saver doesn't work, I don't know but I can confirm it and am checking it out.
I'll be having a look to. The code for the saver is identical to the PC version, and it does receive float data from LW only. I wonder if this is limited to using ot for saving out renders only, or if it also happnes when saving out HDR images using the FP ImageViewer. (that could help to find the root of the problem).

I'll post an update if I can get it fixed.

Cheers,
Mike

jeremyhardin
09-19-2006, 09:10 AM
I'll be having a look to. The code for the saver is identical to the PC version, and it does receive float data from LW only. I wonder if this is limited to using ot for saving out renders only, or if it also happnes when saving out HDR images using the FP ImageViewer. (that could help to find the root of the problem).

I'll post an update if I can get it fixed.

Cheers,
Mike
yes. it also happens when saving from the image viewer FP. that was where I first encountered it and it's true of the f10 saver as well.

Lightwolf
09-19-2006, 09:14 AM
yes. it also happens when saving from the image viewer FP. that was where I first encountered it and it's true of the f10 saver as well.
Allright then, so it seems to be a general problem of the LW saver plugin architecture.
I'll try to fix it, even though I have no clue as to why it may fail at the moment.

Cheers,
Mike

jeremyhardin
09-19-2006, 09:31 AM
but as I said. I'm enjoying the layer saver. I posted one of my tests with it over in the LW9 gallery called Dishes on a Table (http://www.newtek.com/forums/showthread.php?p=438254#post438254).

toby
09-19-2006, 09:23 PM
the commercial version of it includes a layered saver which does work with LW9 on mac.
Bitchin'.

Lightwolf
09-20-2006, 01:23 AM
Just a little update on the issue, before tobiy goes up in flames ;)

Bad news: I've found the issue, and it is indeed a bug in LW 9.0 on OSX.

Good news: I can work around it. I'll prepare a new version later on today, which will include an extra check and only use the workaround on OSX, and only in LW 9.0.

Basically, LW tells a saver what type of image it saves. These types are numerated from 0 to 7 (i.e. greyscale, float RGBA, RGB etc...) in the SDK. On OSX in LW 9.0 this value is wrong (it sends out huge numbers), but the type of image is still in there, just shifted over by 3 bytes, so I can retrieve the value with a bit of trickery.

Cheers,
Mike

Lightwolf
09-20-2006, 01:58 PM
We have solved the issue with OSX not saving images at all using the OpenEXR saver. It seems to be a bug in LW 9.0 on OSX only, but we can work around it.
V1.0a for OSX is now available for download at www.exrtrader.com, we have also updated the main download archive (which also contains the windows version and the manual) to include the fixed version.

I've also informed NT of the bug and added a description of what doesn't work, and how to work around it.

Cheers,
Mike

jeremyhardin
09-20-2006, 03:20 PM
Works as expected. Sweet, thanks!

Lightwolf
09-20-2006, 03:32 PM
Works as expected. Sweet, thanks!
*phew* :beerchug: :jam: :boogiedow

cheers,
Mike who can :sleeping: now...

Caveboy
02-16-2007, 12:00 AM
I downloaded the udpated plugin. It loads the exr just fine. I can save out an exr via sky baker.

But I cannot render the exr with the Image World plugin. I rendered a simpe scene fine with an hdr that I downloaded from debevic.org, but the newly saved exr file does not work.

I even tried the exr file on the pc. Same thing. It doesn't work, but the hdr works.

Anyone run into this problem?

Lightwolf
02-16-2007, 02:25 AM
Anyone run into this problem?
Are you using the open beta version of LW? (there might be issues with it - but thos shouldn't be discussed here)

Contact me via mail (michael.wolf(at)infinimap(dot)com) - and I'll have a look.

Cheers,
Mike

Lightwolf
02-16-2007, 02:49 PM
But I cannot render the exr with the Image World plugin. I rendered a simpe scene fine with an hdr that I downloaded from debevic.org, but the newly saved exr file does not work.
I think we nailed it... the EXR gets saved with an alpha channel by default. If that is disabled in the image editor it works in the Image World plugin.

Cheers,
Mike

Caveboy
02-19-2007, 12:59 AM
That was it!

Thanks!

Dan

Lightwolf
02-19-2007, 01:26 AM
That was it!

Thanks!

Dan
*phew* You're welcome. I thought it was a bug initially... ;)

Cheers,
Mike