View Full Version : config woes 2 problems

09-15-2006, 05:03 PM
Have been having a lot of crashes lately, and am mystified by the current state of config files.

I load up Layout (9) after a crash, and ok, so it's gone to some default configuration. So I load my menu configuration, and reset all the various things like 'use tablet' , # of OGL polys, texture resolution, OGL settings, yada, yada...

Fine. So I shut down so that the configuration will be right if it crashes again before I quit (highly likely). Problem is, I restart LW, and it's bac to the default configuration! Several tries, same result! Am I doomed to resetting everything in the program every time I restart (which is a LOT considering the many crashes of late.) ???

One problem may be that I am running Lightwave from network drive letter (because I hooked up screamernet). So I used the switch to load config files from that place. Problem here is that there is no saying where lightwave will WRITE the config files to -- is there? So I think LW is writing to and loading from different places. But it was still loading my last settings ok, until this last series of crashes, so maybe that's not the problem?

This also causes problems when running screamernet. I have to do the thing where you replace the drive letter in the LWEXT9.cfg to the network drive letter, so screamernet can find the plugins, right? Problem is, after I close down Lightwave, and restart, LWEXT9.cfg has gone back to the old drive letter, having written it over.

Has anyone got a handle on this?

can anyone tell me how to get Lightwave to SAVE the configuration to the same place it loads it from?

thanks for anything...

09-15-2006, 05:32 PM
2 different problems

1. make sure that you are connected to the shared drive and have all rights to write and save on it.
then Lw should write the config files to the shared drive. Sometimes when restarting my Workstation
I don't check if all mapped drives are really connected. If my Y: drive (LW configs and content) is disconnected
and I start LW, it will rewrite new configs in c:/documents and settings/user/temp
So check always that mapped drives are connected.

2. lwext9.cfg treatment is f*ed up. Right now it "works" like you described.

I posted this several times in the open beta. No reaction from NT.

My solution is, make the lwext9.cfg read only as soon as
you have made the right references.
E.g. launch LW then
- alt+F11
- clear plugins
- load plugins from shared drive
- close panel, close LW
- make LWEXT9.cfg read only

Don't forget:
- before you add new plugins make LWEXT9.cfg read/write and after that read only

09-15-2006, 07:54 PM
Thanks for this excellent advice. The 'read only' workaround for LWEXT9.cfg is a great idea.

About #1 in your post, i'm not too clear. The wierdness i mentioned is happening when running LW on the host computer, with the render computer not hooked up. I would hate to think I have to start it up even when I'm not using screamernet? That is probably not what you mean...

I do have administrator priveleges on the host computer, and it has been loading the right configs, until this started happening. Strangely, I went into the default config directory (which lW id not supposed to be using, according to the switch!) and deleted all the configs there (some of which should not have been there, which means LW is writing them there when it shouldn't), and then LW loaded correctly.

what a workflow killer!


09-16-2006, 02:41 AM
Two things:

1. You can (and should) redirect your configs. Use the -0 modifier in the target line in the shortcut you use to launch Layout and Modeler, or use the CMDLine files if you are on a Mac. The procedure is described in your manual.

2. You can turn off auto-scanning for plug-ins in your config and you should if you are using network paths for plug-ins. Turn off Autoscan plugins at the bottom left of General Options in Layout and Modeler.


09-16-2006, 05:01 AM
Hi beeVee, thx for jumping in!
I just tried the "turn off autoscan plugins" and now it seems to work.
In early beta it wasn't the case. So my only solution was the "read-only" LWEXT9.cfg.

Illusory :

my shortcut to Lw :

"C:\Program Files\NewTek\LightWave3D9\Programs\lightwav.exe" -cY:\Programs\config -pY:\Programs\config\LWEXT9.cfg