View Full Version : Null to bones

09-13-2006, 09:22 PM
Is there a plugin like
that will convert nulls to bones for LW 8?

I tried using MGHierarchyToBonesGN in LW 8 on my
Dual G5 (OS 10.3.9) and when I load the plugin it crashes

Can anyone point me to a similar plugin?


magnetic studio

09-13-2006, 10:16 PM
I translated that page, and looked at the PDF that is included in the download and I am still uncertain as to what purpose this plugin would do. Why cant you switch to Modeler and add a skelegon, HUB back to Layout and convert skelegons?

09-14-2006, 06:09 AM
The intent is to convert nulls that have been arranged from FBX import.
The bones that were in the FBX animation are converted to nulls when I
import the FBX scene into LW, hence the need to convert those nulls that
represent the rig/animation.

Hope someone can help....Thanks a bunch.

09-14-2006, 07:54 AM
I'm the author of NtB, maybe I can have a look at your scene and try to fix the problem? I'm a bit short of time at the moment, but maybe next week :P

09-14-2006, 08:09 AM
I do have a scene w/many nulls, but I even tried
a test with two nulls. null 2 parented to null1.
I selected null1 and applied the plug. I checked all except the
one suggested in tutorial, and it crashes.

Thanks for your help.

Magnetic Studio

09-14-2006, 10:36 AM
Which one didn't you check?

Try getting the latest version from my web site, it works with my 8.5, and let me know how you get on.

Ramen Sama
09-14-2006, 07:46 PM
I got a similiar situation.
The script seems to be crashing or something. I've tried it with two nulls and i get the same result.

http://ramensama.dyndns.org:8000/torque skeleton.lws

this is the scene file i need converted to bones.

But the point is the script isn't working.
I'm using LW9, but i've tried it on my old 8.5 install on this same machine.
I'm selecting the parent null, and then running the LS Script.

09-19-2006, 02:57 AM
Did you get the Latest version from this web site?


Ramen Sama
09-19-2006, 04:57 PM
I had got the one from

However, the one on
has an older version of the .ls file it seems. However i used it and didn't seem to have any issue. Thanks for the help.