PDA

View Full Version : Zbrush Node Trouble



sammael
09-03-2006, 01:33 AM
I have been having problems using zbrush 2 displacement maps in the same fashion shown in the LW9 help and the demo video.

I have come to the conclusion that this method simply does not work and is buggy as ****. I am wondering if anyone else is experiencing the same problems?

Following the exact same method as the video I always get a mesh that either just bloats or sucks in on itself no matter what I do with the settings. I understand the way it is supposed to work but I have come to the conclusion that it simply does not work.

BazC
09-03-2006, 02:04 AM
I don't mean to be argumentative here but it amazes me how many threads get started saying this feature doesn't work, that feature doesn't work, LW9 is buggy etc only to find that the poster has made an error.

I don't know if that is the case with you but without more details on what you are doing there is no possibility of resolving your problem and thread simply becomes a rant. I have used ZBrush displacement maps in LW9 and so have many others so either you are doing something wrong or you have found a bug.

I would suggest you post the .lws so we can figure out which! :D

sammael
09-03-2006, 02:25 AM
BazC - I have used various meshes and displacement maps trying to get this feature to work. I have followed the tutorial video exactly, always with unpredictable results nothing like what the feature is supposed to do.
I am not trying to start a rant thread I am simply asking if anyone else is having similar problems.
Yes it is possible that I am doing something wrong. Maybe one of my fellow LW9e users has had a similar problem and found the solution or found what they have been doing wrong?
As for details on what I am doing, I am trying to get zbrush displacement maps to work in Lightwave using exactly the same nodes method as shown in the video!
I take it you have not had this problem then? are you using nodes to control the displacement?
At the moment the only way I can get a zbrush disp map to work is via a 3rd party plugin.
Maybe this thread started off on a bit of a negative note towards LW9, but I guess you could expect that when someone is extremely frustrated with something.
I dont think you can shoot people down for saying LW9 is buggy, because it is buggy, I am just wondering if this is another bug or if i have made an obvious mistake.

nemac4
09-03-2006, 02:40 AM
Make sure you have MipMap Quality set to Off in the Image node.
Use .5 for the subtract node
Also try using ~.25 for the B setting in the Multiply node. You will need to adjust it.
Set Objects Subdivision Order to First

BazC
09-03-2006, 02:46 AM
I understand, honestly I do! I know there are bugs in LW9 and some features are unfinished or poorly implemented. That can be frustrating! Simply asking if anyone else is having the same problems doesn't help you or anyone else though. You are sure that you've done everything right and therefore there's a bug but maybe you've missed something? We all do it! The only way to tell is if you post you're .lws maps and all and see if anyone else can find the problem.

Yes I've used displacement nodes and got it to work but it wasn't straightforward, you have to get the subdivision set right as well as the nodes and it can easily go wrong. I think it could be implemented better but I don't think it's buggy on Mac.

RedBull
09-03-2006, 02:34 PM
Have you loaded the Zbrush scene from the LW9 Content?
As it works for me, and is the same scene used in the Video.

sammael
09-05-2006, 07:36 AM
Thanks all for the replies, I just upgraded my pc this week and now the displacement nodes work as they are supposed to. The only explanation I can think of for my problem was either hardware or software issues, most likely some corruption or something in windows xp. Maybe a graphics card issue... dunno.
Anyway it works now and I am happy!

Im quite happy with my new rig as well I must say, intel e6600, 2gb ddr2, nvidia quadro fx 3400... vastly improves my workflow.
cheers all!

BazC
09-05-2006, 09:01 AM
Glad you got it sorted out! :D