View Full Version : Error- Object is read-only and cannot be modified!

08-31-2006, 08:53 AM
Help! My object (a character with a skeleton rig and morph targets) is now read-only! I looked at the file info/properties it isn't locked or protected. Since the hub isn't working I can't save as another file name (without re-rigging the character). I just want to add new morph targets and change some surface names!

I've tried restarting lightwave...and even restarted the computer. Still locked.

NEWTEK! PLEASE HELP! MAC USERS NEED THE HUB! Lightwave is useless as a seperate modeler and layout with out the hub!

08-31-2006, 09:02 AM
For the time being, the Hub appears to be broken for some Mac users. I have to run with the Hub disabled for Modeler 9 to run at all. Others have indicated the same problem around these forums, though it would be interesting to get an idea how many of us have a dead Hub. Newtek says a fix will be produced "soon" - but Newtek's use of the word "soon" seems to be pretty loose so I'm not holding my breath. Seems like they need a few more Chiltons to add to the one they've got, because he's probably totally overwhelmed with other issues (dead dongles, etc........) so the Hub issue I imagine is a low priority.

08-31-2006, 09:13 AM
Yeah, I know Chilton is one busy dude! I've been sending him my error reports. This is just so frustrating. I went through the beta program - but I was on PC then. We switched to macs because of the stability the same week we got the public release of 9. Now we don't have the hub!
How do you disable the hub?

08-31-2006, 09:21 AM
How do you disable the hub?

Like this. (http://dreamlight.com/insights/10/cmdline_files.html#hubSwitch)


09-11-2006, 05:35 PM
Check how much space you have left on your drive. The Modeler will (inaccurately) give this error message if the hub can't write the temp data. Actually, that last line may be crap, but free up some space it could solve your problem...

09-12-2006, 03:01 AM
And if you are still stuck with a read-only object, you can copy/paste its contents to a new object and save that if need be.


09-13-2006, 09:52 PM
I found I had to set the hub to automatically shutdown in an hour. After that I run the hub.exe first and then I launch the modeler. This has resolved my instance of this problem on my machine. Hope this helps you all....

09-14-2006, 10:54 AM
I am on a PC and have had this happen to me a few times, mainly when I brought an object in from Vue 5i. All I did is used save as or save incremental and then closed the object and repopened it with no problems. I should also mention I was using crack-it at the same time.