PDA

View Full Version : Lightwave Compositing Issue with png



mcj809s
08-25-2006, 02:01 PM
I have what seems to me to be a relativly simple question. Why is it that when you save an image or image sequence in lightwave using a .png format it adds a 1 pixel outline around the image. The 1 pixel that is adds is always the background color. Is there any way around this or another method anyone knows of to do the same thing a different way and get a better result?

stevecullum
08-25-2006, 04:41 PM
I always use 32bit TGA and have never had any real issue. Sometimes the pre-multiply alpha switch in the comping app, adds a fringe so play with that too. Also you could use the matte controls in the compositing app to tweak the edges.

What compositor are you using?

toby
08-26-2006, 12:25 AM
I use .png when I want to save space, but if it's important I use Tiffs, because of this problem. Tiffs have the best alpha I've seen. The matte line you get with png's can be fixed in After Effects by premultiply with white ( assuming you used a black background, which you should ).

Sekhar
08-26-2006, 12:38 AM
What version is this? I don't see any line with LW9 (Win32)...

toby
08-26-2006, 01:22 AM
It's subtle, if you render a white object on a black background then composite it on a white background you'll see it.

:censored: I seem to be getting a matte line with Tif now (?)

And you need to premultply with the color of your background, not what I said earlier - still trying to get a grip on this stuff myself...

mcj809s
08-29-2006, 01:27 PM
Thank you for the reply's. The outlines are still there in all the formats mentioned (png,tiff,tga) The image I am currently working with is just a still so I am comping it in Photoshop. The background was white (used background radiosity) so the outlines are white. They are painfully visable against a black background.

I would love to hear if anyone has solved this problem. I know it's not usually a huge issue, but with professional work and print resolution renders it does make a difference. I would love to find out how to fix it! AHHHHHH Help!!!!!!!!!!!

stevecullum
08-29-2006, 02:24 PM
Thats the problem I'm afraid. You need to render against a black background for compositing or a fringe will be visible.

EDIT: If you need a to use Background radiosity, put a 'matte' black plain behind your object and set alpha to constant black in the render options.

Maxx
08-29-2006, 08:49 PM
Have you checked out the matte defringing in Photoshop? (Layer -> Matting -> Defringe, Remove Black Matte, or Remove White Matte). If you're doing a simple still, this could work for you. Defringe allows you to set the number of pixels to defringe, whereas Remove Black Matte and Remove White Matte are automatic.