PDA

View Full Version : image map transparency problem



illusory
08-24-2006, 08:10 PM
I have a file from Photoshop (cs2) which has color drawing on a transparent background, with varying degrees of transparency. How do I bring it into Lightwave and apply it to my object so the surface shows through, the transparency is preserved?

Sorry if this sounds elementary, but it doesn't seem to be working in 9 the way it used to. But it's been awhile since I've done it this way, and maybe i'm missing something. Or maybe this is yet another LW9 bug problem.

If i save the file as psd, image editor in LW9 seems to indicate that an alpha is there, even shows it when i go to Image editor/Source/Alpha/Alpha Only. (But this alpha is strangely not visible in Photoshop!?) But Lightwave is not using it to overlay the colors from the image map onto the object colors, it just makes the (transparent) background white.

I've even tried making a copy of the same image file, loading it in, changing it in Image Editor to 'Alpha Only', and layering it in the color channel as an alpha mask for the original image! It works there as an alpha, except....Problem there though, that the alpha is inverted from what it needs to be, and "invert" doesn't work for it in the surface editor!!!

Can anyone please shed some light on this situation?
thanks,
NJ

Silkrooster
08-24-2006, 08:21 PM
Did you try applying the same image or alpha only to the transparency channel?
Silk

illusory
08-24-2006, 08:30 PM
I don't wan't the object to be transparent, so, no.

Actually, I seem to have found the problem, and it's in the display. The multitexture OGL settings still don't work correctly, so I'm getting wierd texture displays. Tried an Fprime render, and the hidden alpha in the image seems to work. Didn't at an earlier point, but hey, i won't argue..
Also won't argue with the fact that LW sees an alpha in a psd file, where Photoshop doesn't..

thanks,
NJ

toby
08-26-2006, 12:56 AM
LW sees the transparency in a photoshop layer as an alpha -

illusory
08-26-2006, 02:07 PM
which really helps!:)

esper8
08-26-2006, 03:01 PM
Layout crashes on me whenever I try using PSD files :( However PNG works just fine

toby
08-26-2006, 08:47 PM
Try deleting the PSD.p plugins from the Edit Plugins window, then add it back in.

That's not a common problem, so hopefully this will fix it.