View Full Version : LW 9 error "Object is read only...."

08-24-2006, 02:21 PM
I've just installed my upgrade I've tried loading an object. Whenever I try to modify the object I get "Object is read only and can't be modified". I've tried to merge points, give it a texture, whatever I try to do I get this error. When I load the same object in 8.5 I have no problem modifying the object. Any suggestions?

08-26-2006, 05:55 PM
Have you tried copying the geometry and pasting it into a blank object? Also, have you tried opening it in 8.5 and saving it out as a new name?

I've had this happen to me in previous versions before, and usually one of those two tricks solves the problem.

If that doesn't work, what OS are you running? Did the file itself get locked somehow?

08-27-2006, 04:13 AM
I do believe newtek is working on it, I think it might be the hub or user permissions.

There are other threads on the issue, do a search if marble_sheep's suggestions don't work for you.

Best of luck,


08-28-2006, 06:19 AM
I got a reply from someone at Newtek and basically, it's a bug in 9. This is what he had me do:

Right-click on the Modeler and Layout shortcuts you use and choose Properties. In the Target field it should say C:\Program Files\NewTek\LightWave 9 3D\Programs\layout.exe (and modeler.exe for the Modeler shortcut of course) make sure this path is surrounded in "quotes" then after the end quote make sure you put this exactly:


Space (this is important), minus sign and the number zero.

This is a command parameter that tells the program to not open the hub program. I would like to know if this resolves the problem as it would be a valuable piece of information and if it does not let me know.

It's working fine now. Thanks for your help guys!


08-28-2006, 06:54 AM
That's great news!!!

Looks like they might have it fixed for the update :thumbsup: