PDA

View Full Version : using lw9 nodes render slower?



trang
08-20-2006, 11:00 PM
i also noticed that using nodes o surfaces (which are cool btw) or loading the node presets availbl recently...the render is quite slow even with simple object...box, cone, ball

is it really like this? seem using surfaces instead of nodes renders are faster..

how do you render faster using nodes...is there a way?

ShawnStovall
08-20-2006, 11:03 PM
I haven't really noted a difference.

RedBull
08-20-2006, 11:21 PM
I'll post some example test speeds differences later....

But yes there is definately a noticable slowdown using Nodes.
I'm not sure but it kind of feels like Nodal is sitting on top of the Layer system,
and not instead of..... So i guess we have to evaluate Nodes and the Layer system. But it's not unusual to have Nodal systems slower than there layer counterparts anyway. Power usually comes at the cost of speed..

The slowdown becomes more noticable with FPrime and Viper for example too.
Which is a shame, because FPrime's instantivity is what gives it the edge of XSI's MR region for me.......

trang
08-21-2006, 09:06 AM
a pity as i seems this node system in lw9 appears to be quite powerful...just slower

is there a proper tutorial for using it effectively? i read about some nodes and the schematic pictures but have not idea what goes really where except for the simpler things much less how to recreate them.

thank you for replying so soon

trang

Para
08-21-2006, 09:18 AM
As far as I understand, nodes shouldn't be used for basic shading at all, only when you need to go complex (linking same procedural to several different properties of the surface could be a good example of that). As with all node systems, less nodes means less math for the system to do which of course means faster renders.