View Full Version : red dongle woes....

08-16-2006, 07:51 PM
Anyone find an answer to the red dongle woes? I cannot run modeler (v.9 on winXP 32)...tried to reinstall...and I was supposed to set up bones and weightmaps tonight! I'm hosed since my ver 8 is at work.

08-16-2006, 09:36 PM
Nothing new that I've heard... and while I haven't got anything to specifically produce under deadline, I do have an app that I paid a fair amount of cash for but can't use... and no word from anyone remotely involved with a solution, or even to acknowledge one may be in the works...

08-17-2006, 06:10 AM
I have heard that a solution is being worked on from a Newtek person, but nothing as of yet has been resolved. I think they know this is a huge problem. I will reinstall 8.x and use my dongle between work and home....but I lost 6 precious hours last night that I was supposed to be working. Now my deadline is really going to be difficult....

08-20-2006, 02:33 PM
I'm in the same situation too with the RNBO error .

<edit... got carried away writing...sorry...>

Dual AMD
Red Dongle

Hope they fix it soon before too many others are affected...:thumbsup:


08-21-2006, 07:42 AM
I have been a LW user since it started on a Toaster. I have never seen anything like this. I am surprised it is taking so long to come up with a solution. Its a great app, so don't worry....I bet you will be happy with the $$ you've spent.

For me though it's back to ver 8 till this gets going.


08-21-2006, 10:33 AM

I got 2 emails from Newtek this morning assuring me that they're working on a fix which should come soon.

I'm a first time user so, on reflection, my time might be better spent learning Lightwave than ranting about it. As a wild speculation, I'd guess that Newtek is not entirely at fault here although they aren't pointing fingers.

I agree that it's a great app. I compared it to everything out there specifically for my uses (VFX..not character animation) and featurewise nothing comes close for the price.


08-21-2006, 10:39 AM
Actually, character work is about all I do anymore (some architectural). If you want to go that route, Project Messiah is a useful plugin - but I use the fbx export to Motionbuider to do what I need for character work.

08-21-2006, 11:11 AM
Awright, looks as If I completely missed the boat on the dongle... got another mail that explained the dongle issue may or may not be correct... now I'm just really confused.

Much as it's hard, it looks like patience is just the best course of action. I'm hoping a patch or update comes around before long, and am really hopeful that's not too far off.

As we've said, if anyone really works out what we may be seeing coming along soon, I hope we hear about it.

Anyone else have any updates? I really want to use the app!

08-21-2006, 05:20 PM
Another quick bit, question... does anyone know if the older pruple dongles work with the new software? A friend offered to give his 8 dongle to me as he no longer uses the app, in teh meantime... or am I just making more problems for myself? If a new dongle is then issued to correspond to my s/n, does it just end up goofing things up?

08-22-2006, 08:33 AM
It's not a good idea to mix and match dongles. Once you get a key generated, that key will be locked in to the dongle, and the dongle will be locked into the software. Once we work the problem out, your red dongle would not get a key at all.

Best to let him hang onto his dongle, just for logistical purposes. We should have a solution posted soon, so hang in there. :thumbsup:

08-22-2006, 01:15 PM
Yeah, started to do the math after the post, realizing it was going to create all manner of issues. I think I might actually have him conviced to upgrade to 9 now... after a little email back and forth. Cool news coming? Niiiice...

08-23-2006, 03:52 AM
Man, (I can say that - I'm almost 50) this is driving me crazy - I can even save a relativly small tutorial - and the model I worked on also is to big.

Chris, you guys must know if you are getting close?

08-23-2006, 10:56 AM
We're getting closer, but we're not quite finished. We're going to make sure this problem doesn't repeat itsself, so we're being super careful with the fix.

Hang in there! Help is coming soon. :D

08-23-2006, 12:51 PM
Is it rude to point out that you wouldn't have these problems if you had opted to supply a license server based system option? Is it excessive to ask why this problem wasn't identified in the myriad RCs and test releases?

After all these dongle problems (including dead ones), when and where will NewTek decide enough is enough and that their customers have tolerated the thing for long enough? As ever, the dongle seems to cause much more trouble than it could possibly be worth - it never stops the determined pirates, but it does stop every customer that has this problem, or a dead dongle, in their tracks. Piracy seems a woeful excuse, especially with this latest glitch.

08-24-2006, 07:12 AM
I'd really like to see a sticky in the forums by the tech team, addressing the red dongle as well as the hub issues. It's a bit of a pain to look through the consumer posted topics to find out if there's been a solution or not, yet.

08-24-2006, 04:57 PM
I agree - Chris can we get some sort of notice board for this topic? This started with my thread on Modeller now this one on red dongle - would be good just to log on and see a progress or information update location

Cheers CS

08-26-2006, 08:00 AM
I agree - Chris can we get some sort of notice board for this topic? This started with my thread on Modeller now this one on red dongle - would be good just to log on and see a progress or information update location

Cheers CS

Yeah, I read your thread about 2 weeks ago. This is excruciating!

They've been saying the fix "almost ready" for over a week but also hinting that it won't work for all of those affected.

This guy just got a new dongle:


My IT manager called NewTek today, and a new dongle is going to be sent to us. I suggest if your are having that internal error bug you should call NewTek. It could be that a small batch of dongles were programmed incorrectly. Basically not NewTek's fault.

What I really dread is being told, after waiting for weeks, that I'll need to get my dongle replaced anyway which would be an utter waste of time. If Newtek knows that the fix won't work in certain cases tell us NOW so we can get replacements. Don't make us wait for a fix that won't work.

Anyway, given the lack of details we just don't know.

Throw us a frikken bone here Newtek!!!


08-26-2006, 10:54 AM
As far as I'm aware, Lightwave purchased their new dongles from another company. I dont believe -any- of the red dongles work, but I may be wrong. My second copy of lightwave 9 shipped with a red dongle, didn't work. I sent it in and got a purple which works fine. There's still a few other issues I'm waiting to be resolved, however. I can understand that everyone makes mistakes, but a day should certainly not go by without a techie addressing the issue and giving updates.

08-26-2006, 11:02 AM
Dongle cracks :D If NewTek cannot be bothered to issue regular and useful information or even (gasp!) a fix, it might be the only way for you to get up and running quickly.

08-26-2006, 08:27 PM
Hi guys,

I'm mainly just a Mac guy on NewTek's LightWave engineering team, but I can give you a tad bit of info here. Then I'll probably going to go back to the Mac forum.

The dongle issue started as a Mac problem because the latest version of the drivers we were using were not compatible with red dongles, when using the latest version of Tiger. Some of the red dongles worked on the PC side, or at least some of the ones we were developing with, so we thought it was a Mac only issue. We put together an updated CD, and had it ready to ship quite some time ago. Then it turned out that in our testing, there were some files missing in the install. So we had to rebuild our PC and Mac installers.

Then we found that there was an obscure bug in the dongle driver code for PCs. So again, we rebuilt the installers, got it ready to ship, etc.

And further testing showed that many of the red dongles were just plain hosed. Great. So we ordered 'good' dongles, waited for those, and have started trying to identify who, if anyone, has a 'good' red dongle.

Now we've found yet another batch of tiny (yet important) issues with our help files. So we've got a new round of installers to build, which started on Friday, and will hopefully be ready on Monday.

So if that's ***all*** we can find that needs to be fixed, we'll be able to discuss shipping on Monday. Really, we're as tired of this as you are. As soon as this ships, we can get back to doing the fun work, as in the next version of LightWave, which will be AWESOME.

And of course this has ignited the 'registration server vs dongle' discussion around the office once again.

But hey--NewTek has been accused of having a lack of attention to detail in the past. Be careful what you wish for?

(...going to hide in the Mac forums now...)

08-27-2006, 01:52 AM
Thanks for the update, Chilton. I'm glad the debate has restarted internally as well - I'll wait with interest to see the outcome of that.

08-27-2006, 04:00 AM
Chilton, We are talking about an electronic fix right? I will be really upset if I now have to wait for somthing to be shiped from the U.S.

And you said "monday" - does that mean this monday - as in 28th August???

08-27-2006, 04:57 PM
Hi csoars,

Chilton, We are talking about an electronic fix right? I will be really upset if I now have to wait for somthing to be shiped from the U.S.

It depends. If the dongle you have is *bad*, we'll need to replace it. So far, our attempts to email fixed dongles have been as successful as our attempts to print gold nuggets.

So if we need to replace it, well, let's cross that bridge when we come to it.

And you said "monday" - does that mean this monday - as in 28th August???
Yes. Just keep in mind we're in San Antonio, Tx., which is in the Central Time Zone, USA. It's the same Monday you've already started over there.

Hmm. Since you are already on Monday, any word on whether or not we ship 'today'? Or does that violate some kind of space/time NDA?


08-28-2006, 12:23 AM
Chilton - I am not sure about the space/time thing but I can confirm that nothing has arrived today so don't send it yet. If it arrives tomorrow I will let you know so you can send it.

The donge works OK for the layout thingy - does that mean anything?

I can't even save a wine glass, can't even draw a cog or a planet. My 'space scene' has planets that look like soccer balls.... sigh.

08-28-2006, 02:31 AM
If it's like the old purple dongle, then probably not. Modeler and Layout look at different parts of the internal number grid in the dongle (or at least this used to be the case), so if only one place gets damaged, then one app may be affected.

You used to be able to see this in something like SoftICE, but this was a number of years ago, when I was curious and asked a colleague to look into how it worked :D It may be that the dongle software prevents this now.

I guess the grid wasn't properly set up for the Modeler application *shrug*

08-28-2006, 10:37 PM
A 'solution' is at hand for those affected :


08-30-2006, 09:22 AM
So, the solution is to call Newtek to get a new dongle?

Thank you

08-30-2006, 09:36 AM
apparently so. just got off the phone w/ support. they needed me to email my info and said they hope to have my new dongle and a cd out today. :) :)

08-30-2006, 10:06 AM
I'm mainly just a Mac guy on NewTek's LightWave engineering team, but I can give you a tad bit of info here.
Is it possible that the problem has to do with the dongle ID numbers? That is, it appears there's a batch of red dongles with only 3 digit IDs. This would limit that batch to 999 "bad" dongles. But then the question arises... Why does Layout work just fine with these dongles, but Modeler doesn't? Why would the two apps have different check routines? I mean, this is the third generation of LW, can the two still be so internally different in this area after all this time?

09-06-2006, 10:10 AM
Newtek is mailing me a new dongle...I am sending the old one back. If you are having the same problem....just call tech support.

09-06-2006, 10:19 AM
Make sure you call Customer Support when you get it for your new key though. The new dongle still needs to be 'registered' correctly for it to work, THEN send the old one back.

Also, the program CD has some MAC changes. The PC installs did not change according to my notes.


09-07-2006, 01:59 AM
I can confirm that..When you send in your bad dongle you get a new one (with different id) you then have to get your registration updated and you are issued a new License key..and it works fine (Win)

09-07-2006, 09:45 PM
So, once we've got the disc and dongle (which I do) then I guess the process is this:

Install from the new disc. Plug in new dongle at appropriate time.
Call the support number (um, was told it was the Toaster number, not standard support number... true? something like 1 800 TOASTER?)
They'll get you hooked up with the numbers needed to register and get the new key (based on the serial you provided originally or will provide again)
Proceed with Lightwave Madness!!!

Yes no?

09-08-2006, 08:22 AM
Hm, tried calling and got an automated message even though the hours are correct. (920 AM Central time here now)

Anyone know if anything can be done via email? The support hours are short, and there's no chance of me getting in touch today via phone and I REALLY want to be able to do some work this weekend...

09-08-2006, 02:05 PM
The phone lines open at 9:30am CST. You were just a tad too early. Give us a call any time from now until 5:20pm CST. We'll get you squared away.

09-11-2006, 06:30 PM
Got my new dongle and disk in 2 days from my Tech Support. Per instructions, uninstalled LW, put dongle into USB, installed new LW and everything works like a charm. Now I just need to get the permanent number...

Thanks Tech support.:)

09-11-2006, 09:56 PM
I'm pretty sure the new disk has an update for the mac side only. There was no change to the win 32 or 64 installs from my understanding. Just get the new lock ID and call support. they had me up and running while I was on the phone! :thumbsup: