PDA

View Full Version : Image Node not working???



wesleym
08-16-2006, 02:30 PM
Hey,

I am trying to use the image node to add a color map to my surface and the map is not showing up in the render or texture viewports. I added the Image node and selected my image map, changed Mapping to UV and set my UV Map. I then connected the color output of the Image Node to the Color input of my surface. The texture map is not showing up on my surface.

Does anyone know what could be going on? I can get the layer color node to work.

wes

Bytehawk
08-16-2006, 03:50 PM
does your image have an alpha ?

RedBull
08-16-2006, 03:57 PM
Disable MipMapping!

avkills
08-16-2006, 04:04 PM
The Nodes will not show up in the OpenGL preview at all yet. I doubt it is Mip Mapping. I have Mip Mapping enabled on Node bases images and they do show up during render time.

What I am doing is putting the image mapping on the layers method also so it shows up in OpenGL. When you connect the Node image map to the color input on the surface, it will disable the layers image map at render time.

-mark

Bytehawk
08-16-2006, 06:55 PM
mipmapping:
and if you need it, put in a very low value, seems like this value doesn't react in the same way as in the classic surfed.

Sekhar
08-16-2006, 10:40 PM
This happened to me before. Set the mapping to something else (say Cubic) in the image node, the image will show; then go back to UV, the image will stick, but with the new mapping.

avkills
08-16-2006, 11:30 PM
Have you guys seen a significant difference with Mip Mapping? I've been rendering my hi-res earth in classic and perspective camera and seen no difference in the textures.

-mark

Tesselator
08-17-2006, 10:38 AM
Mip Mapping is currently broken and results can be entirely unpredictable (or
beyond the scope of any reasonable explanation) when using nodes. Just
turn it off - always - and you will be safe from any troubles that they may
cause.

Mip Mapping is partially broken when working with images in layers. If you
are having any troubles using Images in Layers just turn "off" mipmapping
and you should be safe.

That said, when used on the color channel you probably should have seen
something even if it wasn't correct or what you expected so be sure to
check the following items:

- Double sided on/off
- Poly is facing the camera (or not) and is in the camera view. (the new cameras can be tricky)
- The new renderer is very very sensitive to non-planar polys so check planarity. (is that a word? hehe)
- Light Direction and Intensity,
- The Enable Nodes button is checked.
- Other channel values - such as transparency, Normal mapping, etc.
- Render Mode is set to Realistic and not Quick Shade.
- Other?

RedBull
08-17-2006, 01:59 PM
Mip Mapping is currently broken

It should be turned off by default in ALL places in LW, including per surface and in the image editor.....It's a stupid system, that has forced some people to have a DeMip script to do this for us, rather than it being off as default.

Grrrrr!

avkills
08-17-2006, 02:05 PM
Ok, but you say it is broken, but I have not seen anything wrong with images mapped on to objects with Mip Mapping on. What am I looking for? Although I am on a Mac if that makes any difference.

-mark

Tesselator
08-19-2006, 09:26 AM
Use UV mapping or Images for bump, normal, and/or displacement.