View Full Version : A bit of trouble installing LWCAD.

08-11-2006, 01:28 PM
Hey guys,

I've never installed a Plugin for LW before; I can't seem to figure out what I need to do to get LWCAD (1.5) working. I tried the LW V9 installer. I saved the screen that I see when I try to install; but I'm not sure what file-path it's looking for, or how to enter it. I've got my activation key; I just need to actually get it to install.:help:



08-11-2006, 05:38 PM
It's saying your lightwave path isn't defined (the area above the button is empty). Click on the 'Change Path' button and enter or select your LW directory folder (I think it needs your Lightwave/programs folder).

It's been a while since I installed LWCad 1.5, so if that doesn't help, your on your own :D

Seriously though, If you get stuck after this point, post another piccy.

08-11-2006, 05:58 PM
LWCAD was a bit of a pain. It needed to know where it's presets were, and then there was the tab-configuring thing, which was a bit poor.

It's well worth it even for 1.5 though. Num num num. Snap!

08-11-2006, 06:09 PM
Well, it won't let me enter anything in the bar above the path button. When I hit the path button it gives me what I show in the screenshot; but when I select it, nothing appears in the bar.


08-11-2006, 06:13 PM
Gnf. I did have that very thing. Try entering the folder above.

08-11-2006, 06:24 PM
OK, this time it took the file path for the Configuration section (top); but the bottom section wouldn't take anything, I can't copy and paste or enter manually. Selecting the LW 9 Program folder didn't work either. Here's the resulting screenie.


08-11-2006, 08:04 PM
Click on the 'change path' button.
When the dialogue box pops up, click on the 'programs' folder then click on OK. That's it, don't select modeler or layout exes, it's just after the directory name.

Edit - whoops. OK you've done that

Hang on, did you edit your config files at all, you must make a change to the menu's and make sure LW's saved them otherwise LWCad won't install. Also make sure Layout, modeler and Hub are all off when you install. If you've tried all these and you're still having problems your going to be stuck with a manual install.

Here's what it says in the docs, pasting them here for clarity, you should have them in your LW zip under installnotes.rtf :)

Manual installation.
Manual installation is applicable on both platforms.
1. Copy plugin file “lwcad.p or lwcad_mac.p” into your LightWave plugin directory.

Windows example:
copy \Plugin\lwcad.p to C:\Program Files\LightWave [8]\Plugins
Macintosh example:
copy :Plugin:lwcad_mac.p to “Macintosh HD:Applications:LightWave [8]:plugins”

2. Copy Shape Library directory into your LightWave presets directory

Windows example:
copy \Presets\ShapeLibrary to C:\Program Files\LightWave [8]\Programs\Presets

3. Run Modeler.
4. Open “Edit Plug-ins” panel. <alt-F11>. Add lwcad.p or lwcad_mac.p plugin.
5. Open “Configure Menus” panel. <alt-F10>. Add new plugins into the menu.
6. Close Modeler.

Activation & Registration.

Open “LWCAD Options” panel and push the button “Activation”.
Fill out the form. Windows version has also included registration , macintosh version only activation number.
If you get the message “Activation success.”, then LWCAD is fully installed.

In case that registration fails, or you have a macintosh version then use the web registration form here :

If you have any problems or questions, please feel free to contact me. [email protected]

08-11-2006, 09:53 PM
Well, I tested it out in 8.5 first (didn't want to mess anything up in V9); and it appears to work. It's activated, and I'm able to mess with all the snapping options. Now I'll just do the same thing for V9. Thanks alot guys.:)