View Full Version : LScript comander crash.... help

Karl Hansson
02-18-2003, 08:45 AM
I cant use LScript comander. the second I hit the LS Comander button LW crashes. Any ideas? whats wrong? Please help. Is there a nother way to write the LScripts?

02-18-2003, 10:26 AM
hi Karl,
LS commander under 7.5 osx is broken. and has been for some time now.....
it has been officially noted(inseveral places) and reported to the bug list.
it is rumored to be fixed in the latest beta(....no i dont=)
but when we will see it.... or what it will cost.... i would not speculate.

Karl Hansson
02-18-2003, 10:45 AM
Thanks. I was about to reinstall LW... ;) Is there any other way to write lscripts? How?

02-18-2003, 11:43 AM
Is there any other way to write lscripts? How?[B]

yes...buy a wintel computer,seems to work fine there(said with a hint of disgust):mad:

02-18-2003, 12:38 PM
You can make LS Commander work on the Mac. First, you cannot be running LScript 2.5.1, it must be 2.5, so if you've upgraded, replace the Lcore3.shlib with the original from the CD. Second, you will need to make sure your disk permissions are corrected in OS X. (Applications:Utilities:Disk Utility - First Aid).
Third, you will need to delete any preference file that is related to LScript:
LScprit Prefs, LS/GN Prefs, etc.

At this point, LS Commander should work fine. If, for some reason, it fails again in the future, just remove the LScript specific preference files and try again.

Karl Hansson
02-18-2003, 01:40 PM
That didnt seem to work... thanks anyways. I did as you said replaced the lcore3.shlib with the one on the CD. I veryfied and repaired the disk under the Disk Aid in disc utilities. And then I removed the LS prefs.

I couldnt even start LW when I done that. Some mw.carbon.shlib error accured.
Any Ideas?

02-18-2003, 02:45 PM
My Mac OSX brothers here is your guardian Angel. (my name is Angel you know)

I made an Apple Script to make LSCommander work again every time you use LW. Just run my script before you run LW. The script will delete the offending files and Launch LW for you.

get the Script here (http://http://www.motionblurstudio.com/downloads/angel_script.sit)

hope that helps

-your guardian angel

02-18-2003, 05:53 PM
Are you running OS X?

LW unable to start is quite confusing. I would suggest you compare what's on your 7.5 CD to your Programs directory, and see if (somehow) you've managed to misplace more than one file. The only file you should have had to replace or move in the Programs directory was lcore3.shlib. There is a complete, uncompressed version of LW on the CD, just look for the programs directory an make sure that all the files on the CD version are in your Programs folder as well. Deleting preferences from the Library : Preferences folder should not kill an application.

You should only have had the ability to repair permissions on your boot disk (I'm going to assume that's what you meant), not repair the disk, unless you booted off of another disc or CD.

"Angel" has had the Applescript solution out for a while, I have never needed it, since my system does not suffer the problems of LS Commander crashes that others have mentioned. I have heard good things about it, though.

Karl Hansson
02-18-2003, 11:36 PM
Im under OS X 10.1.

I dont know if my version of disc utility is older than yours or something because it doesnt mention anything about discpermissions. So I did reboot on to the startup system CD and using the disc utility on the startup cd I verified the disc wich turned out to be fine. But to be sure I ran a repair anyways.

The LW CD I have is LW version 7 not 7.5. You think that because its not the same version swiching the lcore3.shlib doesnt work?

I swiched back the original lcore3.shlib file and LW worked again. So there must be something about the (7.0) version of lcore3.shlib that LW7.5 dont like... you think?

Karl Hansson
02-19-2003, 11:04 AM
Anieves method seem to work fine. So far I have only had to delete the "Command Window Prefs" ones and now it works. Thanks Anieves. And thanks all you other guys. Your guys are the best!:cool:

02-20-2003, 10:29 AM
Karl, you can get the utility at Apple to repair disk permissions for OS 10.1.x. It's built into 10.2.x. After using the disk permissions utility, and deleting the offending prefs once, I'd be curious if the problem is solved continually. As I mentioned, I've never suffered that problem with my system.

And yes, the lcore version with 7.0 would kill 7.5. Sorry about that. I (foolishly) assumed you had a 7.5 CD.

repair disk permissions utlity, OS 10.1.x:

03-01-2003, 09:29 AM
Originally posted by paintboy
Is there any other way to write lscripts? How?[B]

yes...buy a wintel computer,seems to work fine there(said with a hint of disgust):mad:

Actually, I've had some problems with LS Comm on a windows 2000 pc. I had been getting the same problems as described above(crashing lightwave) but couldn't find a solution anywhere on the internet. After reading your comments, I though it might have been due to a preferences setting problem as had been discovered for the mac's. I searched through the windows registry and deleted some offending registry keys and all is fine now.

Just thought I would post something in case anyone else with a Wintel machine ran into the same problem.

02-11-2004, 06:51 PM

what did you delete i go the same problem :(

02-11-2004, 06:56 PM
got it

using regedit.exe
under user-> Newtek-> lscript core-> WindowCommand

what i stuff about hope this is fixed in lw8
i wasted half my day :(