PDA

View Full Version : BRDF test



Michael
07-30-2006, 09:22 AM
Can someone with both 8.5 and 9.0 test this on their machine.

-Go to Modeler, create a shape (box, ball, etc).
-Save the object and put it into Layout
-Open the surfaces panel and apply the BRDF shader
-Open the shader and uncheck the light in the scene
-Render the scene

If everything works the way it should, the object should only be lit by the amibent light, and will appear very dark.

Mine works in 8.5, but not in 9.0...am curious if anyone else is having the same situation.

Michael

Sarford
07-30-2006, 01:14 PM
Yep, I have the same 'problem' although I have to say, I have no idear what this shader does :P

Michael
08-02-2006, 10:44 AM
Thanks for your help...Anyone else verified this? :help:

BRDF, amoung other things, allows you to exclude lights on a surface-by-surface basis instead of object-by-object. While there are work-arounds, the functionality of the BRDF shader makes things easier in certain circumstances.

Michael

soletread
08-05-2006, 05:10 AM
I have had endless hassles with the BDRF shader. Even in 8.5. It tends to forget what lights it should be using. I fix this by opening the surface editor and click the BDRF shader and then click edit and close. This refreshes and the original setting is restored.

Actually I was hoping for a node that would exclude lights per surface. Can't seem to get that to work yet.

duke
08-05-2006, 08:01 AM
BRDF is whacky and I tended never to touch it. If you're using 9 which I assume you are by posting in the 9 forum :P, just use nodes for your layered specular needs.

Michael
08-05-2006, 03:09 PM
It is a bit more difficult than that. I am actually using BRDF to exclude a certain lights from affecting a surface, not just specularity. I have worked around the issue by placing the surfaces into a different layer and then simply excluding the lights, but then run into another problem with some translucency and some other surfaces that are suppose to receive light that don't now that the surface is excluded from the lights in the other layer.

To put it bluntly, BRDF was the only way I found to resolve all of my lighting issues. I would love to figure out a way to exclude lights from the nodes interface, but I am a newbie to those concepts. If anyone can give me a point in the right direction, I would certainly appreciate it.