View Full Version : Found my first bug in 9

07-26-2006, 12:24 PM
i don't know if any of you are having this problem, but there seems to be a hub problem in 9. everything was working fine now all of the sudden i can't open modeler without deactivating the hub. thought it could be a firewall problem but i tried shutting down my firewall and modeler still wouldn't open with the hub. anyone else having this porblem or heard anything about it?

07-26-2006, 02:45 PM
Yeah, quite a few of the open beta members are experiencing this as well. Best bet is to restart your computer 'til it works. Deleting your configs may help, but it's not a for sure thing. I'm pretty sure NewTek is aware of this bug.:lwicon:

Oh yeah, if you run without the hub Modeler will be fine.


07-26-2006, 02:49 PM
Look around the forums and you'll find a handful of current threads about this. I had to nuke my software firewall. Newtek is getting some heat for this too-common problem.

07-26-2006, 03:35 PM
Found my first bug in 9

Won't be your last!


07-26-2006, 03:43 PM
Chilton is aware of it, on the Mac side at least. I'm not running 9 on a PC so I can't speak to that side of the issue.

What I haven't figured out yet is HOW to run Modeler 9 without the hub on a Mac. I've never had problems with it before so I never had to fiddle with it. Is there a simple setting somewhere to tell the Hub to not start when I start Modeler? Because it automatically runs when I run modeler, and even if I quit the hub, Modeler still crashes anyway. This is really bizarre because it doesn't happen with Layout (at least not on my machine) and I've never had a problem like this with the previous versions of LW I've been using. Totally confounding, it is.

07-26-2006, 04:01 PM
If you want to disable the hub on the Mac, you need to edit the CMDLine files that match LightWave and Modeler and just put in -0, save and quit. That's minus zero.


07-26-2006, 07:16 PM
yeah i'm running it now without the hub and it's working fine. but it's a pain in the @$$ cause i'm at a point were i'm switching back and forth between layout and modeler. it's weird because layout hasn't given me any problems with the hub at all.

07-26-2006, 07:32 PM
I generally don't use the hub unless i have to... I think i've seen this before Lightwave9 too... When it happened i found the way to resync them was to close HUB,Layout and Modeler down. And then try launching Layout and Modeler from the HUB..

Right clicking on the hub, and clicking launch Layout or launch Modeler
should make them communicate between themselves.

If not i'd say it's a security/firewall issue. What firewall are you using?
Turning off Security Center, and Windows Firewall, as well as any third party firewalls, is often the solution as mentioned by others.

07-26-2006, 07:54 PM
No problems with the hub here.

Found this when I opened it :thumbsup:

07-26-2006, 08:19 PM
Doesn't work here either, did for a while after I deleted my configs, but is now bust again.

Tried quitting my firewall, no effect.

If I run Layout F12 makes the hub popup a message (when you bring it's interface up) saying "Can't Open Application".

If I run Modeler after running Layout it locks both apps up (and the hub).

Definately disabling the hub until this gets sorted.

The annoying thing is this behaviour was reported throughout the Public Beta and yet it's still there in the final release.


07-26-2006, 08:35 PM
The annoying thing is this behaviour was reported throughout the Public Beta and yet it's still there in the final release.


Strangely, I didn't have any problem until the final release. :bangwall:

07-27-2006, 02:00 AM
I take it someone has pointed this bug out to NewTek! We could all be assuming everyone else has done it and NT aren't aware!

Hardly likely though!

07-27-2006, 02:56 AM
Whatever I do-run with or without firewall-online-offline, everything works perfect.
If it was a LW-bug, I should have it to-or am I missing something here?

07-27-2006, 03:10 AM
try stopping windows firewall service. So far it works for me.

07-27-2006, 08:12 AM
This is wierd! Need to take some things out of the loop, or find a commonly installed program / config on all those machines that have issues!

07-27-2006, 09:30 AM
i'm running the computer assciates internet security suite. it's strange because it was working fine for the first week i had it and then all of the sudden i started haveing the problems. for a while layout seemed to be working ok, now it seems to be giving me problems too. i'm not using the windows firewall and i tried some advice i got on spinquad of stopping the windows firewall/internet connection sharing (ICS), but that didn't work either. i tried shuting off my ca firewall and that didn't make any difference either. actually yesterday i turned my computer on and everything worked fine again. then i left for the day came back at night and started haveing the same problems again. this is very frustrating.

07-27-2006, 09:40 AM
well i just tried starting layou up again and it worked fine. modeler almost never works and layout seems to work pretty consistently.

07-27-2006, 09:41 AM
I'm not sure how effective turning off Windows firewall will be - I'm having similar problems but I'm on a Mac, so it seems to be a more Lightwave/dongle driver-specific issue than an OS issue. Chilton's aware of it, on the Mac side at least.

Thanks Ben for the info, I'll try that when I'm back home at my Mac.

07-27-2006, 11:57 AM
so as far as i'm concerned if it's having the same problems on both platforms then it must be a lightwave issue.

07-27-2006, 01:19 PM
Okay guys something to try (worked for me, but dunno for how long!)

Bring up your Windows Firewall (whether it's enabled or not - mine wasn't as I use McAfee Internet Security Suite). Go to the Exceptions tab and add 'layout.exe', 'modeler.exe' and 'hub.exe'.

07-27-2006, 03:13 PM
The only problem I'm having (so far, I've only had it installed for about 24 hours) is that Layout crashes when shutting down the program. It will shut down if I start it and do nothing but shut it down. If I do anything in layout, it will crash on exit. Shutting down my firewalls had no effect (Windows Firewall, Sygate Personal Firewall, both have exceptions for lightwave).

One interesting side effect of the crash is that my task bar which is set to autohide no longer hides until I restart the computer. I don't know if that is useful information or not.

Windows XP Pro
AMD Athlon 1700+ (1.47Ghz)
320Mb RAM

07-27-2006, 05:09 PM
Speaking of random crashes, has anyone ever had Modeler bomb when you open the (non LW) file requester and just leave it there, usually while browsing your desktop (that has many files on it)?

I keep running into this odd one.

07-28-2006, 04:08 PM
i can confirm this strange behaviour - each few days LW freezes by start. I need to restart comnuter, delete configs, do some magic etc.... very annoying since I can't recognise the pattern :(

07-29-2006, 05:02 PM
BeeVee's suggestion worked! I just edited the Lightwave and Modeler cmdLine files to contain "-0", and Modeler runs fine now. So apparently the Hub was the source of the problem. Seems to be the source of a lot of problems....

07-30-2006, 04:39 AM
I have the same problem with LW9. If I start modeler without -0 switch, it freezes. Sometimes it freezes my whole Windows, so I need to reboot computer.

I even tried it with clean install of windows and same problem. I don't have any software firewalls installed, and tried it without hardware firewall and same problem.

This is really annoying bug, hope they'll fix it soon.

07-30-2006, 05:04 AM
I had this same problem, and i have resolve it, just by add layout, modeler and hub to exception list of my firewall, and i have delete lwhub9.cfg file and since the problem is not reappeared .