View Full Version : F9 and F10 Quit Layout

06-07-2006, 05:36 PM
I have a scene at 7800 by 5400 and when I hit f9 or f10 it quits out of lightwave. It does not do this in lower resolutions. I have image viewer off and have turned off render display. I know I have heard of this one but again I forget the solution. Any help would be appreciated. Thanks.

Edit: OK now getting an error message saying not enough memory for frame buffers. Not that big of a scene, oh well. I have 2 gigs. Guess I need more headroom (PC WinXp)

06-07-2006, 07:07 PM
Weird. Still getting a crash. According to my scene stats I should have planty of memory. Something else? I seem to remember this happening before. Anything else to check?

06-07-2006, 08:24 PM
For what it's worth here's my scene stats. I am at a bit of a loss here. What am I missing? I seem to have plenty of head room. Tried another scene at 6000 by 6000 and it crashes too. As you can see my scenes are lot too large. I am not sure what to do. I have print work to get done.

Thanks in advance.

06-07-2006, 10:08 PM
Sounds like a memory issue...
When programs are critically low on resources, they will tend to just drop out without any messages...

At that res, it sounds feasible to be having that problem..
LW64 and some more ram, or perhaps render in segments and strips, or use
limited region or various plugins on flay, that help with large renders.
You can also use LWSN.exe which uses less memory than Layout.exe

The W Stats panel, most likely won't help as it doesn't show how much the render is taking up...... Try looking at the taskmanager when you press F9.
You will likey see the problem there.

06-07-2006, 10:14 PM
Thanks for the response.

Though now I notice that with limited region very small it still crashes. I even put segment memory down to like 4 megs. But if I use the resolution multiplier to 50% it renders - even with segment memory bumped up to 256k.

There seems to be something wrong with the resolution setting. Why would it crash still with segment memory still so low? This does not make sense to me.

I keep trying with some of your tips.


EDIT: looked at the task manager. It still shows I have 1.5 gigs of RAM available with the scene loaded and when I hit render it did not budge, LW just closed.

06-07-2006, 11:29 PM
Shut down the PC and restart, shutdown the hub. (just to clear Windows memory) Remove any uneeded programs, antivirus, services..
Are you running any shaders or image or pixel filter?

It may be something in your scene that LW does not like,
try replacing the object with a similar polygon amount or object,
take out 1 thing at a time, to see if you can replicate in another scene.

If you have 1.5Gb free at rendertime, (not after it's crashed)
It shouldn't give you the framebuffer error.

It does sound like the resolution is the killer though. smaller segments usually help, renderstrips is a plugin that has helped me in the past.

* Do you or have you used FPrime at all?

06-08-2006, 01:55 AM
You might have hit something there. It seams to me I recall a post awhile back of LW crashing when rendering when I beleive tiff or jpeg was being used. What happens if you try another texture?

06-08-2006, 02:32 AM
I'm willing to bet it has nothing to do with geometry, but image use. How many images? What size? What format? That'll be where your memory is going and to find out how much they are taking you'll need to go to the Image Editor, you won't find it in Scene Statistics.

Here's a PDF I wrote with Lightwolf on the subject of image use.


06-08-2006, 04:14 AM
According to his stats pic above, no images are used in his scene.

06-08-2006, 04:19 AM
D'Oh! Teaches me for posting before engaging brain... :(

Still, good advice in the PDF, I promise! :D


06-08-2006, 04:29 AM
When does it crash? I mean what's LW doing when the problem occurs ?

just before it crashes, is there any message appearing in the render panel (Lw outputs what it's currently doing in the lower part of the render panel - things like 'rendering volumetrics, moving object xxxx, freeing image buffers etc)
Maybe the information there could help

doesn't sound like a memory problem to me since you set the segment as low as 4 megs

06-08-2006, 10:46 AM
It just quits straight out to the desk top when I hit F9 or F10, that is, when it is done with any other messages such as "turn off render display?" etc. It never gets to rendering. Then sometimes it will get to the render screen and display the error message "not enough memory for frame buffers"

I have tired restarting closing other programes etc.

I have tried it with a completely different scene/objects and the only thing that does it is the pixel amount -anything 6,000 or above. 5400 works fine.

I also tried to reconstruct the scene in another scene file.

Silk: I remember something about that too. I'll look into it further.

That'a all I can think of for now. I am going to do some more testing and see if any of these suggestions lead to anything.

Thanks guys....

06-08-2006, 08:39 PM
It looks like a memory issue for sure based on my tests. Thanks guys for all your input and info. It was a great help. I'll download that PDF too Ben, thanks.