PDA

View Full Version : EPS Export of UVs



Philbert
04-23-2006, 05:11 PM
For some reason one of my fave plugins, UV Imaginator, is crashing Lightwave, So I decided to try using the Encapsulated Post-Script everyone raves about. It did the job nicely, but there's a line being drawn from 0 in UV space to each point on the mesh, which is nearly 25,000 lines. This makes it look really ugly and blocks some of the detail in the lower left corner. Anyone have any ideas for getting rid of those? I tried unwelding the model first, but no luck. TIA

Silkrooster
04-23-2006, 09:24 PM
In the export eps box, is options to disable the grid and points, when exporting.
However, the grid is useful for letting you know where the objects are. So I usually create another layer and paint on that new layer. Then when saving the file, the grid lines won't show. By adjusting the transparency of that layer, you can see the grid below for texturing, then return the transparency to normal, when you save the file. Oh, make sure you fill the background of the new layer to white, before creating your textures.
Silk

Philbert
04-23-2006, 09:43 PM
I think you may have missread the first post. It's not a grid, it's thousands of lines coming from 0 (the lower left corner) and going to vertex points on the map. Like so:

http://www.philnolan3d.com/images/temp/eps_error.jpg

I've found out that these can be deleted in in Illustrator pretty easilly, but it would be nice to have them not be there in the first place.

Sekhar
04-23-2006, 11:42 PM
Hide other surfaces (showing only the UV surfaces) before exporting. Works for me.

Philbert
04-23-2006, 11:49 PM
Thanks I'll give that a shot

Silkrooster
04-24-2006, 04:10 PM
Sorry about that, it looks like the uv map needs to be edited. Try unwelding the points, delete that point then weld. (theory)
It looks like they share the same point, which just happens to be in that corner.
Question for you, did you happen to try heal uv command? Usually you will see red dots where they share the same point. heal uv will create exactly what you have.
Silk

Philbert
04-24-2006, 05:04 PM
Hmm, I've never seen this Heal UV tool before, I'll have to look into that. It does seem that hiding everything that's not in the map does the trick.

AntonyScerri
04-26-2006, 09:55 AM
I would be interested to know what you find out about your object and its UV map. Im the author of the UV Imaginator plugin, so if its being killed by something I would like to try fix the problem. I suspect whatever is causing those additional lines (something in the UV map points I suspect) is causing my plugin to crash. If you do find out the cause and get the EPS to output correctly, could you try my plugin again and see if it still crashes.

If you could send me the object with UV so I can debug the plugin that would be great.

Thanks

Tony

Philbert
04-26-2006, 10:23 AM
Hi Tony, Thanks for writing this great plugin. It is still crashing Modeler. I'd be happy to send the model if you give me your email address. It does appear to be only this model, I just tried it with another one and it worked fine.