PDA

View Full Version : Problem using the DELETE key?



Craiglet
05-24-2003, 06:06 PM
Greetings... I'm using LW 7.5 on my G4 running Jaguar for a couple of weeks now (my previous experience with it is all on PC) and oddly, in Modeler, my Delete key does not delete... doesn't do anything as far as I can tell. The only way I can find to delete selected geometry is to do so under the Edit menu, which is obviously not ideal.

I have tried remapping the delete key to the delete function in the hotkeys editor, with no result. I dont think its my hardware, as the key functions normally in every other app I use.

Anyone know anything about this or have any suggestions? Thanks...

JackDeL
05-24-2003, 06:18 PM
This gave me fits too! Make sure that you are using the "delete" key that sits in the corner between the "end" and "ins/help" keys.

;)

Craiglet
05-24-2003, 06:36 PM
Thanks for the quick response, however, my keyboard only has one delete key... there is a CLEAR num lock key on the numeric keypad... unfortunately that one doesnt work either.

My G4 is a couple years old, so the keyboard isnt the latest greatest newest model, but works just fine. They keypad has four small HELP/HOME/PG UP/PG DN (which i dont recall ever using for anything) across the top to the numberic keypad and the aforementioned CLEAR key above the 7, but thats about it...

Help!

lord
05-24-2003, 07:22 PM
Sounds like you've got one of them nasty cut down keyboards they shipped with the imacs.

Urrrughh nasty mistake that one, specially if your left handed cos the right hand option and control keys were missing too. What were they thinking?

What you need to do is get yourself a full size keyboard. Dosn't even really matter what brand of keyboard you get either as far as I know. I've used a PC brand keyboard on my mac before. Just as long as it's a full size one and uses USB.

Beamtracer
05-24-2003, 07:58 PM
Early model G4 Powermacs shipped with the cut down keyboard. It was a Steve Jobs special, and shipped with the hockey puc mouse.

As an alternative you can go to the edit menu at the top of the screen and select 'delete'.

Craiglet
05-24-2003, 09:03 PM
hmm... as far as i know it is a full-sized keyboard. it has the f-keys along the top, full sized "12 key" numeric keypad on the right side (which is actually 22 keys)... however it did come with the hockey puck mouse (which i still use)

i'm attempting to attach a pic i just snapped of it... we'll see if it works... (not sure what that 'max size: 0 bytes' thing on the post form means.)

maybe i could map the "delete" command to another key? like an f-key or something? all seems kinda crazy to me...

and yes, beam, i realize i can select delete from the menu -- that's what i've been doing, it just takes a little longer... and we all know those wasted seconds add up!

Craiglet
05-24-2003, 09:12 PM
well it was worth a shot. anyway, here's my keyboard...

http://www.kenquasar.com/keyboard.jpg

lord
05-24-2003, 09:23 PM
Yup, as I said, I'd take a trip down to your local store and grab a full USB keyboard. Don't know how you can stand using that thing.

Here's a full keyboard. I've circled the area that has the second delete key that your missing.

You'll also notice that the arrow keys arn't tucked tight up under your shift key as well and that there are fifteen function keys not 12.

Cheers,

Lord

CoMetX
05-24-2003, 10:20 PM
Another, more cost effective way is to simple hit the "x" key. This will work exactly like the deleate key, or at least i think it does. Anyway, hopw this helps.

-CoMetX

eblu
05-24-2003, 10:43 PM
Originally posted by CoMetX
Another, more cost effective way is to simple hit the "x" key. This will work exactly like the deleate key, or at least i think it does. Anyway, hopw this helps.

-CoMetX

thank god for a voice of reason. CometX is right, dont throw a way a perfectly fucntional keyboard. heck even if you cant get used to the X key, you can Always Map the appropriate behavior to Whatever key you want!
I know what your thinking, "why doesnt it work properly now?"

well the short answer is that Lightwave Modeller is a pc program ported to the mac, and the "delete" key conveniently positioned actually is the backspace key to a PC. Lightwave Modeller doesnt respond to the backspace key, unless you change it to do it yourself, which is not terribly difficult.
so what are you going to do? spend 79 bucks, or change your preferences, and save 79 bucks?

lord
05-24-2003, 10:49 PM
Personally I'd spend the cash rather than suffer using the mutant mini imac keyboard.

:D

You're right though I guess, you can use the X key - which is the shortcut key for the Cut function.

Incidentally I think Craiglet has tried remapping his keys without success.

Craiglet
05-25-2003, 05:50 AM
Cool... Thanks everybody... Your responses have been very helpful...

I just started playing with editing my keyboard shortcuts again. There's no assignable BACKSPACE key that I could find. F11 is unused in the default config and is conveniently located just above the delete key... er... backspace key, so that seems like a pretty good workaround for the time being. It's a much smaller target but at least I can use the same finger I'm accustomed to without having to change my whole hand zen, LOL. It's difficult enough going back and forth in LW from Mac to PC platform on a daily basis, what with the one button mouse et al, which I do...

The X key is clear across the keyboard and would have the side effect of replacing whatever's in the clipboard, so that's not so good for me personally.

Doesn't seem like it would take much -- future versions of LW really ought to address this issue in the Mac port. At least allow us to remap it to the backspace/delete key...

Well, thanks again. :)

eblu
05-25-2003, 07:51 AM
Craiglet, I'm not in front of LW at the moment, but there is a mapping for that key. Trouble is that its not called backspace. I cant remember what it is called, but for some reason I think its an Fkey. Its a very weird workaround, but it Can be done. I myself have been subjected to that particular keyboard, and with a little sleuthing I have avoided the very problem you are describing. try doing a search in this forum and the old forum, because i seem to recall an official Newtek workaround for this problem.

RobinWood
05-25-2003, 12:47 PM
Hi Craiglet! I have exactly the same keyboard that you do, and I've successfully mapped Delete to the delete key on the keyboard. Thing is, it's not in the list as "Backspace," it's "(BS) Ctrl-H" for some reason.

There was something there already, so I had to move that, too; but it now works as you would expect. Here's a screenshot (http://www.robinwood.com/DiscussionGraphics/MapDelete.jpg) of the Configure Keys requester, in case I'm not making myself clear (happens a lot.)

If you can't get this to work for you, let me know, and I'll post the configure file on my website for you to grab. (With that file, all you'll have to do is Load, of course.)

Craiglet
05-25-2003, 06:18 PM
SWEET! Thanx Rob... You are absolutely correct and it works exactly as it should. Yay!

Glad I didn't follow lord's advice and run buy a new one... :D

For anyone curious, the BS Ctrl-H key was default mapped to 'Polygon Selection Mode'... no loss there, I'm quite used to either clicking the button on the bottom of the screen or tapping the space bar.

Much obliged! I think I'll go delete a bunch of stuff now... heheh.

Jimzip
05-25-2003, 06:29 PM
I re-mapped delete to CTRL-LEFT (That's control, and left).
No dramas.
Close Object is CTRL-Right

Jimzip:D