View Full Version : SurfMixer - Failure to render correctly.

05-24-2003, 03:47 AM
For some wierd reason surfMixer will work fine with VIPER (and the small preview sphere in the surface editor) but rendering loses the bumpmapping mix?

I don't understand? SurfMixer works fine on 2 other machines... One at work, one at the University. Both in VIPER and Rendering.

Maybe I should completely purge 7.5 and re-install? However I really would like to know why its working in VIPER and not in the rendering? I've blown away the configs already, and done a reinstall of the 7.5c upgrade patch (Repair).

Anyone have any other ideas before I get desparate? Bug? Or my machine?

05-24-2003, 03:51 AM
And here's the good VIPER preview - As you can see, the bump maps are visible (and in the surface preview sphere).

Like I said, rendering works fine on two other machines.

05-24-2003, 12:08 PM
I have no clue. I could not get it to work on my machine. Maybe it is something that i'm doing wrong.

Chris S. (Fez)
05-24-2003, 08:35 PM
Argh! Bump mapping is not working with mixer on my machine either. I just specifically set up a bunch of normal maps for use with surface mixer. Please, Newtek, assuming this is not user error, if you have a fix or a fixed file please post it. Don't make us wait months for such a useful, powerful tool. Thanks.

05-25-2003, 01:42 AM
Phew! So its not just me then... :)

Now, like I said, I've had successful renders on two other PC's with the same tool - In fact, it was only when I really got back from the LWUG that I thought I would experiment a little more at home - Its wierd that this PC isn't working though?

PC I'm using has:
GeForce4-Ti4200 with latest NVidia XP drivers, Win2K, 512Mb ram, and I have only a light array of video and graphics tools (no dial up, printers, etc installed).

The PC at work with similiar specs (its got 1Gb ram) is running a Ti4600, but the drivers are very OLD detonator ones (29.xx) seems to not have problems with SurfMixer at all.

Why the low end drivers? Stability - The March 2003 XP drivers from NVidia caused LW to 'take down' windows (as in severely (lock up and reboot)) - I had the exact same issue here at home with the same NVidia drivers - However seems that the newer XP drivers don't cause the same problems...

The machine at the University is a stock SGI-230 (PIII-833, 320Mb ram, 30Gb drive, Quadra Pro (Pre-GeForce4!), Win2K). This machine also appeared to work with SurfMixer.

I dunno if any of this relates to this plugin, however? I would assume some kind of small bug in the plugin... Hmmm...

Dick Ma
05-25-2003, 12:59 PM
it seems that the surfmixer isn't belong to any plugin.

May be we have to wait for LW 7.5d (or LW8)

05-25-2003, 01:42 PM
To bad they dont provide the code so we can see how it works. That way when we expect an update every 6 months we could fix it our selves or improve it.

05-26-2003, 04:41 AM
Hehe! An OpenSource GNU LightWave upgrade project! Nice idea... However there's a whole SDK and scripting system for anyone who wants to take a stab at writing something like this themselves! :)

Heres an interesting observation I made between the 3 machines (I will have to double-check with the two other machines later this week to make sure they REALLY worked - I am starting to doubt myself - Maybe I was looking at VIPER and not the render? Hmm...)

Anyway, I noted the following:

was a direct patch using the 20Mb patch file from 7.5 to 7.5c - SurfMixer didn't work

Work PC
Patched from 7.5b to 7.5c - SurfMixer Worked (but will confirm in case I was mistaken)

University PC
Was patched 7.5 to 7.5c, however with the 15Mb patch file - SurfMixer Worked (Again will need to check a second time just to be sure)

Makes me wonder if perhaps the 7.5c (15Mb version) patch has some kind of Bug fixes we didn't know about, and just maybe the 7.5c (20Mb version) needed 7.5b installed first to work properly?

Anyone else here actually have a working Plugin installation for SurfMixer? Like I said, I'm sure that I've seen it work on 2 machines - But I will definitely double-check tommorrow at work that I was correct (or that it doesn't work there either - In which case the plugin is truly buggy (or only does colour channel?))

Hmmm... :confused:

Dick Ma
05-26-2003, 12:36 PM
Color surfaces blend only, but bumps not blend.

Viper shows the blend results but it also contains error:
polygon normals flip when render..

Just a little accidental:

7.5c can installed without previous versions (7.0b or 7.5b)

but no presets!

05-27-2003, 03:51 AM
Thanks Dick...

You're correct - My doubts were confirmed today when indeed I tested the VIPER/Render on the machine I thought had worked - And well, it didn't. :( And now I think about it, I used VIPER at the LWUG to demo the effects quickly when mixing surfaces... So no, I don't think it worked there either...

Hmmm, pity - The effects look really cool in VIPER - Perhaps having them also work in the render would be even better! :)

Chris S. (Fez)
08-21-2003, 08:51 AM