PDA

View Full Version : BRDF shader bug



Beamtracer
05-22-2003, 09:32 PM
Lightwave has long had a bug with the BRDF shader. I wondered if this has been fixed in LW7.5c?

For those not familiar with BRDF, it's a shader used to create 'anisotropic' reflection effects in Lightwave. This is useful when you want to achieve photorealistic reflections, for example like the paint on a car. There is a tutorial to explain this on Worms of the Art website:
http://www.the-worms-of-art.com/tutorials/lightwavetutes_221.html


On the old Newtek forums there were colorful discussions more than a year ago about how using the BRDF shader in Lighwave 7.5 would cause their systems to crash...

http://forums.newtek.com/discus/messages/2/22478.html?

The issue has also been covered on Julian Johnson's Mac Lightwave website, including a bug in BRDF that sometimes causes weird artifacts in your renders:
http://www.exch.demon.co.uk/

Has BRDF been fixed in LW7.5c? After all these years, is it safe to use yet?

Capt'n Hector
05-22-2003, 10:55 PM
My computer doesn't crash when using BRDF, however sometimes (read, most of the time) I'll get small patches of pink (or is it purple, I can never tell) in my renders. Humm.

luka
05-23-2003, 12:09 AM
well a great way to test if it really works is use the default caustic ring scene either the fast or slow one.and add the BRDF shader to it.:(

Beamtracer
05-23-2003, 12:20 AM
The situations that BRDF fails (in LW7.5) were well documented over a year ago in the links above. What I want to know is if these problems have been resolved with LW7.5c.

I'm currently still using LW7.5, as I'm not yet game enough to install LW7.5c.

Darth Mole
05-23-2003, 02:59 AM
Beam - I'm happy to report that BRDF on my system doesn't seem to crash or cause any weird pixels.

BUT, I have to say, I'm feeling very lucky: I am experiencing none of the problems that others are. Modeller works fine, and no real bad bugs in Layout for me. I don't push LW too hard, but I was modeling all last night, and then using the Pshelf presets (a lot of which use the BRDF shader) with Hypersmooth and Shadow Designer and nada - not one crash.

I use a dual 800 with 1.2Gb, OSX 10.2.6 and a GeForce3 card. Clearly, I have the magic setup so if anyone wants to buy it, it'll cost ya!

Darth Mole
05-23-2003, 03:12 AM
Although, having said that, DV view does gives me the same blocky display. Ho-hum.

Beamtracer
05-23-2003, 07:18 PM
I was thinking in terms of crashes happening when BRDF is used in combination with Digital Confusion or Caustics, and color artifacts when BRDF is used in combination with raytraced reflections.

head worm
05-27-2003, 05:35 AM
We have written a long tutorial about using the BRDF shader.

Most of the problems with it actually occur because of the quirky way it works, rather than bugs as such.

The artefact issue has not occured for me whilst using Lightwave7.5c, but I suspect that this is coincidence. Newtek are almost completely uncommitted to sorting small issues like this out until major releases.

The cure is usually to quit Lightwave and re-run it. I've never had artefacts and the amazing radioactive effect (that occurs on PC - so don't think you're hard done by) persist after a restart. It's crap but a workaround.

Cheers

Head Worm
www.the-worms-of-art.com

luka
05-27-2003, 08:03 AM
Somebody slap me. I just did my old brdf test with caustics and the scene rendered. I will test with more complicated scene just as soon as I peel myself off the floor:)