PDA

View Full Version : Newbie: Enable Deform scrunches character



lwsalvatore
04-02-2006, 05:08 PM
I am a newbie rigging my first character. I have constructed an upper body bone hierarchy using the LW 8.5 bone tools.
All bones are rested and active.

The problem is that when I click on the Enable Deformations button, my character scrunches down vertically (see comparison pics).

I thought that resting bones would put the character in an initial state of no deformation. Then clicking Enable Deformations and rotating bones would then cause the deformations.


All bones have same falloff: inv distance ^16
My object has only one layer and contains the bones.
(bone properties say Use Bones From Object).
There should not be any other bone influences working.

I have attached the scene file and character object if any one would like to
explore further.

Thanks.

toby
04-02-2006, 10:44 PM
I took put the scale of all the bones back to 1 and that fixed it.

As far as I can tell the 'r' command doesn't rest scale. Try setting the 'rest length' instead of scaling bones.

Or do all your bones in modeler ( skelegons ), where you can use any tool you want -

lwsalvatore
04-03-2006, 03:01 PM
Thanks for the re-scaling idea.

I tried to scale each bone back to 1 by selecting each bone individually, hitting the space bar until i am in the scale mode (as opposed to position or rotation mode) and entering a 1 in the X, Y, and Z boxes (near the grid info display). I make sure to tab through each text box so that the values are accepted.

However, the scale values of bones I previously changed revert back to their non-1 values as I proceed up the hierarchy.

Is there a simple way to change the scale of all bones to 1,1,1 ?

Thanks again.

toby
04-03-2006, 11:03 PM
With the scale tool selected, and the character or one of his bones selected, use "select all the bones of current object" in the classic scene editor, (top left) and hit 'Reset' on your left toolbar under the animation tab.

It also sounds like you have 'auto-key' turned off, which is fine, but whenever you change a value you will have to set a key for it to stick. The Auto-key on-off is at the bottom-middle of the main window.

SplineGod
04-04-2006, 01:03 AM
You should just leave enable deformations on by default. It doesnt do anything very useful the way it currently works.
Its best to keep the object and bones in the same layer (less thinking). If you do have them in separate layers make sure as Toby mentioned that you tell your object to "use bones of" and let it know which layer the bones are in.
Bones must be RESTED ( r key) to be able to deform the mesh. I usually set the bone falloff fairly high (around ^128).
DO NOT confuse the stretch or size command with rest length. They have nothing to do with each other and will only screw things up if you confuse the two.