PDA

View Full Version : Newbie Can't Render SubPatches



evilkillerfiggi
04-02-2006, 01:15 PM
I've only recently started using Lightwave, having graduated from a short previous history of Anim8or.

I'm on Lightwave 8.5, and have a SubPatch model, which doesn't render as well as I'd hoped. Apart from large amounts of pixellation, I'm also finding random lines from the non-subPatch model being included in the final rendering. I'm assuming that either I've accidentally drawn these in somehow or I've got to toggle some setting somewhere, which I've been unable to find (albeit I haven't spent a great deal of time searching for it).

Help would be appreciated.

evilkillerfiggi
04-02-2006, 04:32 PM
Here's a pic of a Sonic the Hedgehog model I was working on. There's construction lines around the back spikes and nose, and if you look around the eyes the picture isn't smooth.

http://viewmorepics.myspace.com/index.cfm?fuseaction=viewImage&friendID=54697827&imageID=621346875&Mytoken=1202B988-B104-10D0-600BD1A0652153EF58584485

richdj
04-02-2006, 04:38 PM
Makesure the sub-div order ( in the objects properties) is set to last, and if that doesn;t work try increasing the antialising level in the camera properties..

Hope this helps..

Rich

evilkillerfiggi
04-02-2006, 05:42 PM
Thanks very much, that solved the low quality problem.

It's still showing construction lines from the non-subPatch model, though. Are these a common problem or is it likely that I've gone and accidentally created extra points that are confusing the renderer?

Amurrell
04-02-2006, 06:03 PM
I would think that the construction lines that you are talking about come from another layer that is rendering with the one you really want to show. I'm not sure, because I don't know how the scene is set up. Sounds like you have a non-subpathced model as a background layer in modeler? I would hide this from the camera or marking it as unseen by camera in layout or remove it from the scene all together or delete the layer in modeler and save the project as a seperate file.

Another thing that you want to look at is having the sub-patch rending level set at about 3 or 4 and use smoothing on your surfaces. Sub-patches look smooth in modeler, but in layout they will look like a bunch of squares when rendered unless smoothing is activated.

evilkillerfiggi
04-03-2006, 10:23 AM
Solved the problem- There weren't any other layers or anything, I just had to go and change the Particle/Line Thickness in the model's Properties to 0.0.

Am proceeding to play with render settings to improve quality. Thanks very much for all help given.

evilkillerfiggi
04-03-2006, 05:27 PM
Solved the problem- There weren't any other layers or anything, I just had to go and change the Particle/Line Thickness in the model's Properties to 0.0.

Am proceeding to play with render settings to improve quality. Thanks very much for all help given.

Eldorado
04-03-2006, 06:19 PM
evilkiller what?! figgi ??

peteb
04-04-2006, 05:53 AM
I reckon it's where you've welded or merged polys and been left with 2 point polys like someone mentioned above. To solve this do what they mentioned which is to hit W in modeler and look to see if it says you have 2 point polys, make sure you're in poly mode. Then hit the plus sign to the left and then hit delete.


Pete B

evilkillerfiggi
04-06-2006, 02:41 PM
Deleting the 2 point polys causes most of my model to vanish along with them, so I've left them in as they're for all intents and purposes invisible now. However, I'll defintely be careful of them in the future. Cheers all who helped.

Oh, and Eldorado: 'figgin' made it too many characters ^_^.

evilkillerfiggi
04-06-2006, 04:51 PM
Thanks very much, bryphi77, you were right. I had the object's own weight again in single and double vertex polygons, which were only showing up in the rendering. It's much much cleaner now. Cheers.