PDA

View Full Version : HELP!! Spline help?



ianay
03-19-2006, 12:12 PM
I built this (human)head using Spline curves....
this is what happens when i sub-patch!! (hope you can see the pics OK!)
Ive only been using Lightwave a few months and this was my first attempt with Spline curves.
What have i done wrong?
Any help much appreciated!

Dodgy
03-19-2006, 12:24 PM
Merge points! :)

ianay
03-19-2006, 12:46 PM
thanks for that
Mergin the points fixed about 95% of the odd lookin polys...
I now have about 6 or 7 of these unatractive polygons and have no idea whats causin them!
Any help?

kruemel_1
03-19-2006, 01:57 PM
With the defaultsettings of merge points only point exactly overlapping gettings merged. Maybe there are points with a little gap. Use the mergepoints with a fixed distance which is lower than the pointdistance of your mesh.

Dodgy
03-19-2006, 01:59 PM
Try unifying polys. This will get rid of any polys on top of each other...

ianay
03-20-2006, 10:21 AM
Ive tried all the above and this is what im left with...
the front of the head /face is fine but this.....
Its really driving me insane!!

Im ready to chuck the whole thing in the bin!!

Help!?!?!

Giacomo99
03-20-2006, 11:14 AM
I hate to point this out after you've done all that work, but you need to be keeping your mesh resolutions constant...you've got 2x2 patches bumping right up against 3x3 patches, and the round edges are occurring because the points aren't aligned. Some of the other problems might be occurring because your splines don't share common endpoints (they need to)--but it's hard to tell.

There's no single magic solution here, other than "you need to be more careful when setting your splines up." If you test-patch your splines *as you build them* you will be less likely to have these kind of problems. Simply building all your splines and then hoping they'll patch correctly is going to give you endless grief, especially if you're a beginner.

GM

ianay
03-20-2006, 12:06 PM
Thanks for that...
Back to the 'drawing board'
Hopefully Ive learned from that error!
Thanks again for any advice guys...
I appreciate it

SplineGod
03-20-2006, 01:54 PM
I usually layout the splines that define the overall form and flow. At that point I dont care about whether they form correct patches. Once I do that THEN I add in the extra splines to make the patches work. That also sometimes means removing or changing splines, splitting them or merging them where needed and making sure that they line up with each other using the curve smooth tool so I can avoid any strange kinks.
As Giacomo said, I also make sure I use the same number of polys (when I can ) per patch but not get too many.
The basic idea is to get a basic form and flow that you can then tweak further in subpatch mode.
Ill also recommend my Modeling a Head With Splines video. It covers all this in great detail including tweaking the final head in subpatch mode. Its almost 4 hours long and its still on special for $24.95 for another day or so.
http://www.3dtrainingonline.com/head_splines.htm

kiwi dave
03-20-2006, 03:45 PM
Hey ianay, if you can afford to splash out a few pounds, SplineGods tutorials are winners! Will really get you over that frustrating "want to model it - can't do it" stage.

Dave

Lewis
03-20-2006, 05:21 PM
HI !

Your OTHER problem (beside Merge points what you solved now) is that you probably have N-Gons and they can't be SubPatched in LW currently (subject to change in Lw 9). You must have all polygons with 3 or 4 points no less no more.

cheers