PDA

View Full Version : LightWave No Longer Starts...



NinjaApprentice
03-19-2006, 01:37 AM
Recently I tried running LightWave 3D for the first time in a while. For some reason, it just doesn't start anymore. The Dock icon bounces for a few minutes, and then it will simply stop. It does not even show the small black triangle that indicates that an application is running. I end up having to force quit the program. This happens with both Modeler and Layout.

I've tried reinstalling, but the installer ended up crashing while running the installer script. I later found the source of the problem; by using the Activity Monitor to view the active processes on my system, I found that force quitting "DongleCheck" caused the installer to continue normally after "crashing", until it got to the end and ran "TempKeyGen". Force quitting "TempKeyGen" caused the installer to finish normally. I assume LightWave is doing something similar, although "DongleCheck" does not seem to run when either Modeler or Layout are launched, so they will always just sit there no matter what I do.

I noticed an older thread that says that nobody has had many problems with upgrading Mac OS X to version 10.4.5. However, all of the problems I have been having seem to have started ever since I made the upgrade. My computer's other important specs are as follows:

iMac G4 (20" model)
768 MB RAM
LightWave 8.5

Any help at all would be appreciated.

magnetoz
03-20-2006, 02:55 PM
Have you tried trashing the prefs?

NinjaApprentice
03-20-2006, 03:20 PM
I tried it just now, and it doesn't seem to have worked.

One other thing I learned since I posted is that, when I open the application bundle for "DongleCheck" and "TempKeyGen" and look at the application inside of the Contents/MacOS folder, the Get Info window lists it as a Classic executable. That may be part of the problem; I would think it should be a PowerPC executable. Does that show up the same for anyone else?

fabmedia
03-26-2006, 01:21 PM
Did you do a clean install of the OS? Archive and install has some serious issues. I would delete everything LW and reinstall.

NinjaApprentice
03-26-2006, 08:06 PM
I don't exactly see why that would only be a problem now, considering that I've used OS X 10.4 almost since the day it was released. Actually, I've had 10.4 long before I even had LightWave. Why is this only a problem now?

I'd really rather not reinstall the entire operating system. I don't have an easy way to back up my 76 GB of used hard drive space. But I may have no choice...

timschmidt
03-29-2006, 08:20 PM
Dude! I have the same f*cking problem! I got Tiger way back when it was released. Had problems installing LW8, but someone on here help me get it running. A couple weeks went by where I didn't use it and now it opens for two seconds then closes and tells me it crashed. I'm about to try reinstalling it again for the millionth time.

I hope version 9 works better... This makes me a sad Timmy.

NinjaApprentice
04-06-2006, 11:49 PM
Well, even though this topic seems dead, I thought I should mention that upgrading to the new 10.4.6 version fixed the problem. Thanks anyway, everyone.

fabmedia
04-07-2006, 09:25 AM
It sounds like the update installed something that might have been corrupt or deleted by accident.

I'm glad that things are working. What I would do, is post a series of events that led up to LW not working. It would give us all an idea what to watch out for. It could also save your fanny next time.

NinjaApprentice
04-07-2006, 03:14 PM
What I would do, is post a series of events that led up to LW not working.
I guess I could, but it's a short list:

1. Don't use LightWave for about 1 1/2 months
2. Install update 10.4.5

I honestly don't think I did anything else that could have possibly messed up LightWave. I think it was Apple's fault in the end, because the newest update says that it fixes "compatibility with third party applications and devices". That sounds like "we screwed up LightWave and probably other stuff" to me.