PDA

View Full Version : Boolean intersect errors



cedox
03-10-2006, 01:20 PM
I am trying to blow up slowly a very finely beveled plate:

28812

The whole thing is made by intersecting the smaller parts into the bigger thing. It should be closed, I've tried to pull most of the bevels where they connect to >4 polygons.

When I try to cut pieces with boolean intersect/subtract or using C4: Shatter/CrackIt plugins (Super great tools, thank the maker) I don't get good results. Where the other object cuts (was it a box or a sphere) it doesn't make all polygons and some polygons are totally wrong.

Because the explosion is slow and I go to slow extreme close-ups before it I'd like to blow the thing as it is. As in not make a low-polygon version of it cause it would be visible with slowly rolling animation.

Any hints what could cause this and what to do to fix it? Tripling polygons didn't help either.

- Cedox

toby
03-11-2006, 04:06 AM
Have you tried Drill or Solid Drill? They're much more reliable.

cedox
03-12-2006, 02:21 AM
Yeh, tried all three operations. Solid drill breaks polygons just like boolean operations. I really don't want to manually patch the cuts as I'm going to break the plate into dozens of pieces.

I tried it with another object and it doesn't handle boolean operations either, solid drill worked though except it whined a lot about highly coplanar polygons for a long time even if I twisted and jittered and turned the drill object.

28890

Is it so that these algorhitms can't handle polygons which have concave, beveled, unioned polygons.

Silkrooster
03-12-2006, 06:42 PM
What version of lightwave do you have? Pre 8.3 couldn't handle as many points per polygon. Which would cause havoc with booleans.
Silk

toby
03-12-2006, 08:53 PM
Could it also be that the points on your boolean object are lining up with the points on the boolean-ed object? You can't boolean points from points, so that does cause problems -

parm
03-13-2006, 12:28 AM
Very slightly Changing the size of the shape,(1mm or 0.5mm), you are using to cut with, often helps.

As toby has already pointed out, points that line up exactly generate errors.

cedox
03-16-2006, 09:08 AM
The shape of the drill object isn't the problem. Version is 8.0, so having polygons made of dozens of points (fonts) drilled is the likely cause. I made one font, tried to cut it and got similar errors. Also crackit said object wasn't closing perfectly which it was though(unless not closing perfectly means it has to consist of quads). All polys were planar, too. Tried tripling and got same errors.

Thank you silkrooster, I update newer version of lw on the other comp and try again. Thanks others, too.