PDA

View Full Version : image mapping question about decals



keith23
05-19-2003, 09:43 AM
This may be an elementary question, but I can't figure it out. How do you get a background color to show through around a decal? Below on the right are two .psd images. I made the red circle as a test, and when applied to a surface, it allows the blue background color to show through, as seen on the right. The race car decals will not allow the blue background to come through, as seen on lower right. Why?? They are both psd images with transparent backgrounds! Somebody please help!
Thanks.

JulianW
05-19-2003, 10:41 AM
You need to make sure you're saving it in a 32bit format (so the alpha channel is included) 32bit Tif works nicely.. then you should just be able to apply it as normal (the Alpha Channel option in the Image Editor should automatically set itself to Enabled)

If that doesn't work you can always save out the alpha channel as a seperate image and apply as another layer of texture with the blend mode set to Alpha.


JW.

keith23
05-19-2003, 11:26 AM
Thanks Julian, but how do you save it as a 32 bit in Photoshop? I looked under Image/Mode and for tif only see options for 8 or 16 bit files.

I tried a workaround solution and just painted in the desired background color (black) on the image. Then when I mapped it onto the uv surface, I got an entirely new problem!! As you can see below, the "black" image only shows as a narrow band, while the otherwise identical "white" image covers the entire uv surface as it should. What gives here?? This is driving me crazy!:confused:

head worm
05-19-2003, 12:23 PM
Hi,

There isn't a 32bit option as such. When you elect to save as a TIFF, there is a checkbox for 'include Alpha Channels'. RGB images are normally 8bits per channel - which adds up to a 24bit image (8x3). If you add on an extra Alpha channel for stenciling out areas, that's another 8bits and so the image becomes 32Bit (24+8)

The transparency in your image is not saved as such, you need to create an alpha channel that reflects which areas you want opaque and which you want to be transparent. White means opaque and black means transparent.

i rarely use the 32 bit option myself, as it's been known to be unreliable moving between platforms. Generally I turn the alpha channel into a separate JPG file and put it into a separate texture layer, set to 'Alpha' blend mode. This will then act as an alpha channel to the layer directly BELOW.

Whichever method you use, a grayscale stencil is required. You can't just create transparent areas in Photoshop docs and have them show up in Lightwave :o(

Cheers

Head Worm
www.the-worms-of-art.com

keith23
05-19-2003, 01:11 PM
Well, thanks to both of you who responded - very much appreciated. The good news is, I got it to work. The problem seemed to be a screwy(?) alpha channel in both photoshop files, which I deleted. Once I did that, the "black" image mapped perfectly- not just a narrow band. Then I tried the "white" image with the alpha channel deleted, and low and behold, the background image shows through! Actual background color will be black - I just used red for example. So, apparently you can get a transparent background in PS to show up in LW without using alpha channels. The file that finally worked was simply the same .psd, 8 bit, RGB, with no alpha channel. I still don't know how that strange alpha channel got in there! Obviously, I'm no whiz at Photoshop.:rolleyes: