View Full Version : Lightwave Vt4 users transparent backround help

Seti Orion
02-26-2006, 04:09 PM
I made a simple animation in Lightwave.
I would like to overlay the animation over some
video footage in vt edit.

Can someone please tell me how to do this with lightwave and Vt4 ?

What render options?

Anything else?

Tom Wood
02-26-2006, 04:18 PM
One way to do it would be to render out an image sequence with Alpha - LW_TGA32 or LW_PNG32 and take those into Aura (part of VT4) and render out an RTV from there.

You can also render out an RTV with Alpha from LightWave.


Edit: Render(tab at top)>Options(sidebar)>Render Options>Output Files, then select either Animation or RGB files, or both.

02-27-2006, 06:15 AM
In LW you can render as a TGA-32 or PNG-32 sequence. Then just bring the first frame of the animation sequence in to the VTEdit timeline, this will load the entire sequence, & turn on overlay for this clip. That's It! No need for Aura.:thumbsup:

02-28-2006, 08:01 PM
the .RTV render option with alpha. That will also perform well as an overlay and will not take up all that space in your file bin for an icon for each .tga frame in the animation.
Render option>Output files>Type>Newtek-RTV Options>Alpha Mode>Save Alpha

If you haven't done the "Edit Plug-ins" routine that RTV option isn't there yet. So be sure to run that first.

Good Luck on the Lightwave! It's a blast.

03-01-2006, 06:39 AM
The downside to rendering to any animation format vs. rendering a sequence of TGA's or PNG's is that if on a long render the system crashes or shuts down for some reason you loose all of that render. Rendering out a sequence lets you start from the last frame rendered. Trust me I learned this the hard way!

Or let's say you want to make a change from frames 450 to 600. With a sequence you just re-render these frames..........Waaaaay Better.:beerchug:

03-01-2006, 07:21 AM
The downside to rendering to any animation format vs. rendering a sequence of TGA's or PNG's is that if on a long render the system crashes or shuts down for some reason you loose all of that render. Rendering out a sequence lets you start from the last frame rendered. Trust me I learned this the hard way!

For this reason, I usually render both. The time difference is not signifcant, and then I've got the RTV ready to roll when it is done, but if something weird happens (power outage, etc.) I've got the frames saving what work was completed.

03-01-2006, 08:11 AM
Billmi, Good point,:agree: I forgot to mention that option too!!??:question:

Seti Orion
03-14-2006, 03:25 PM
I tried everything you guys said but I could not get
my rendered object to have a transparent backround?

I know I'm missing something

Pretty Please more detailed steps

03-14-2006, 03:35 PM
After rendering to RTV with alpha, you'll need to turn on transparency for the layer when you bring it into VT Edit.

Seti Orion
03-14-2006, 03:43 PM
where do i turn on transparency for the layer at exactly?
Light wave vt4 toolshed ?

Where exactly please

Seti Orion
03-14-2006, 04:25 PM
A few guys gave me a few different ways to do it.
I have tried all of them for hours along with all kinds
of other things and nothing has worked

Can someone please explain each step very clearly
with all render options and things I have to do in
Vt 4

Tom Wood
03-14-2006, 05:20 PM
Lower lefthand corner of the VT screen, select the clip in the timeline that you want to be an overlay, then check 'Overlay'. If you've saved the RTV with alpha, then the transparent parts will become transparent. Note that the 'bottom' layer has to be at the top of the VT timeline, and the 'top' layer underneath that.


Seti Orion
03-14-2006, 05:25 PM
Yeah i know about overlay

Still cant get it to work and I have tired all kinds of things

and steps I could be missing you guys can think of?

03-14-2006, 09:49 PM
Can you tell us about the animation? For instance, what is in the background? What is in the foreground? Have you accidentally activated the "add environment" tab in the Backdrop options? Or chosen a gradient Backdrop? Or selected a background image in the compositing tab? Or clicked on some fog options maybe? Is there an object (black box) filling the camera view behind your animated objects?
Just looking for the un-obvious.

Seti Orion
03-14-2006, 11:02 PM
I'm just doing a very simple cheesy test.

I created a 3d ball in modeler sent it to lightwave
put a image map (picture of me on it)
played with the surface editor settings a little
and then tried to set up the render options
exactly like you guys told me.

Thats it as far as I know lightwaves setting are on 8.0 default. Is there a way to make sure all setting
are stock?

Sorry for the newbie question

WHat am I doing wrong?

03-15-2006, 11:37 AM
Rendering from LW to RTV, can anyone point me to a site to down load, or send me a copy of the plugin?
lw6_vt.p or something like that. Mine went away during one update or the other.

03-16-2006, 10:12 AM
1) In Lightwave render options are you setting the render format to TGA-32?
2) Just drag the first frame (KeyTest0001.tga)of the animation onto the time line (This will automatically load the ENTIRE SEQUENCE) below what ever clip you want to key over & turn on overlay for the TGA sequence!! We use this all the time!!!

Seti Orion
03-16-2006, 05:54 PM
here is a picture of all the settings I got so far
I have tried many other settings but maybe this will help


what am I doing wrong?

Seti Orion
03-16-2006, 06:18 PM
what other settings should I show pictures of
to make sure I'm doing everything right?

Is there a way to set all of lightwaves
settings back to default?

03-16-2006, 08:05 PM
Maybe you should try rendering as Save RGB without the alpha channel to 24-bit TGA. If that background is not an object LightWave will render it as transparent, which could be the cause of your issues. Is the background an environment? It looks to me like you don't want the alpha, just a straight RGB render of that scene.


03-16-2006, 09:50 PM
In your save menu, I noticed that you are using the third option in the menu, save alpha...

Instead, try to use the second option and use the TGA32 file format. I've attached an image to show this... This works for me all the time.

Hope this helps.
-Kevin P.

Seti Orion
03-17-2006, 11:35 AM
that was it!

thanks you guys very much!!!!

Rgb was the call

Seti Orion
03-17-2006, 12:01 PM
now one to next issue when I overlay
the rgb there is jagged edges around the object in vt4
edit but I dont see them in lightwave?

I tried high quality + ISS contrl tree settings?

03-17-2006, 01:18 PM
Hi, What level of antialiasing are you using? It's best to use at the very least enhanced low antialiasing or better. This will smooth out edges as well.

If this is not the issue, make sure overlay is on and, as you already mentioned, you are on High quality. If you are not scaling the image, you don't need to use ISS, although it sometimes helps with images that have fine lines that have "twitter."

Re: High quality... as others have mentioned on the boards, high quality is best, but sometimes low quality is just fine and in fact better than medium quality... a strange quirk.

Good luck,

Seti Orion
03-17-2006, 01:36 PM
where are the antialiasing settings?

Seti Orion
03-17-2006, 06:17 PM
I found the camera AA settings!

I tried medium it took way longer and only looked a little
better. I see a lot of options to mess with it is going to take time.

I was wondering if I upload a 3d ball with a video on it
if one of you guys could show me what settings you used
exactly to get rid of all jagged edges.

03-18-2006, 06:24 AM
One of the things to watch for is how many segments you used to create the ball. The more segments the smoother.

I would suggest working through some tutorials, they have quite a few online. 3D Arsenal has some great presets and it is a good way to jump start your LW skills. Talk to your Newtek dealer.


Seti Orion
03-18-2006, 01:35 PM
3 arensal stuff looks great.

One thing though is that on there wedding pack demo I noiticed even they had some jagged edges too?

Is that because of watching it on my laptop screen?

So you are saying by getting 3d arsenal they have tutorials
on rendering and address jagged edges?

I got a lot more tests to do myself, I got a feeling to get
rid of jagged edges the renders are going to take
a long time.

03-18-2006, 02:42 PM
3D Arsenal doesn't "fix" anything. It does have many scenes that you can look at to see how they are set up or use.

Working through tutorials and disecting scenes that already exist is one of the best ways to learn LW. If you can find a class somewhere it would help. If there's a LW user group in your area, even better. EBay has lots of LW tutorial videos for sale. Dan Ablan's books are pretty good as well.


03-18-2006, 02:52 PM

Hmm, just in time.


Disclaimer: I have no relationship with the above listing, I just noticed it and thought you might be interested. :thumbsup:

Seti Orion
03-19-2006, 12:59 PM
I have Dan Ablan lightwave 8 course which is great!
I went through it once already and learned a lot.
I'm going back now to hunt down rendering tips
and antialaising tweaking etc...

Dans course rocks!

Its looking like if I want no jagged edges I'm going to
be wait for a long time with the highest quality
AA settings.

Thanks for the help guys

Any last words of advise?

Seti Orion
03-19-2006, 03:52 PM
After a bunch of tests I found some settings that
are much better and exceptable!

It still seems like I can tweak things out and get even better but for now I'm happy!

Thanks everyone

03-25-2006, 12:46 PM
I did not follow all of the thread but make sure you enable fields or motion blur.
Take care,
Jose Burgos