View Full Version : Yikes! 7.5c update makes Modeler crash at launch

05-16-2003, 09:18 AM
Not that I needed to but I installed 7.5c on my iBook to make sure it works before I put it on the work mac.

Downloaded it, ok.
Run the installer, ok.
Run LW to see, ok, 7.5c on the titlebar.
Run Modeler ... crash ... boom ... did not even get a glimpse of the workarea.

Haven't had any problems with 7.5 on this machine.

OS X 10.2.6
iBook 800Mhz G3
384MB memory

Anyone else has the same problem?

05-16-2003, 09:40 AM
Yes, I am getting the same Modeler crash when I installed 7.5c!
I checked layout first, and it worked great. Even the DVview plugin works great.

I am running OS 10.2.6. I hope we can get this resolved quickly. I like some of the plugin updates in 7.5c for mac.


05-16-2003, 09:53 AM
*waits for 7.5d

05-16-2003, 10:30 AM
I wonder if the old modeler will work in a 7.5c environment. Will give that a try first on Monday.

05-16-2003, 12:45 PM
remember to log these issues formally with Newtek tech.

05-16-2003, 01:03 PM
I'm getting the same crash problem from the Modeler only. I still had LW7.5b installer and I try 7.5b Modeler and it Booted correctly with all the 7.5c installs.

B&W G3 350mhz .... soon to be 800 mhz
ATI 7000
1Gig RAM
OS X 10.2.6

05-16-2003, 03:04 PM
Why is it that it's getting harder and harder to find software that you can use without jumping through the hoops of bugs?

I actually paid for Carrara 2 to see if I could just use that for simple projects that I would output to Flash, etc. (I'm still learning Lightwave). It's loaded with bugs and they haven't fixed them.

Macromedia is famous for carrying over old bugs and not issuing free updates. Flash 5 was out for Windows for 2 years with not a single free update.

Is there a developer out there that can get their software working the way it's suppose to?

Sorry for the rant.

05-16-2003, 04:19 PM
Installed 7.5c on my PB 12" G4 640M Ram OS 10.2.6, no crashes so far on either Modeller and LW.

05-16-2003, 04:31 PM
crashed Modeler first few times i tried, but worked consistently after that. don't know why.

05-16-2003, 05:03 PM
I just updated to 7.5c with no problems, in either Modeler or Layout.

I'm using OS 10.2.6 on a 400 MHz G4 with 704 MB of ram.

Even the third-party plugins that I've tested (G2, Hyper Smooth, Shadow Designer, Ozone, Tree Designer) are working perfectly.

05-16-2003, 07:27 PM
From the posts it looks like Modeler crashes on G3 but not on G4 machines.

05-16-2003, 07:48 PM
I moved all my config files out of home/Libraries/Preferences and now I get an error instead of a crash, red exclamation mark on the dialog and everything:

Application Launch Failure

The application "(null)" could not be launched because of a shared library error:

Anyone knows what that is?

05-16-2003, 09:33 PM
Hey.. Im on a G4 dual 500, and I get a crash when I boot up the LightWave app. My modeler works perfect, but as soon as I open layout, I get some strange message saying that it can not read something. I can't remember, sence I uninstalled it and went back to previous version of 7.5. I don't know what to say really, they want us to buy there software for a high price and yet, it comes with more bugs then you can handle. As for now, ill stick with my old version of LightWave.. Im really hopeing they get the ***** in gear, because the mac side of this program is lacking. Oh well, back to the "no reduce polygons" side of things.


(edit) I'm also running 10.1.5. Not sure if this is the reason or not? I guess I could always make the jump to 10.2... ;)

05-16-2003, 10:38 PM
No crashes so far here.

G4 400
Radeon 32Mb

05-17-2003, 01:07 AM
Modeler run's fine on my Dual 800 G4 but crashes on my G3 laptop.

I was running lightwave modeler and layout fine on my G3 before the lightwave update. Now Modeler always gives me an unexpected quit error.

Specs on my G3 Laptop

400 mhz
512 megs of ram
osx 10.2.6

Specs on my G4
Dual 800
ram 1.25
osx 10.2.6

05-17-2003, 09:33 AM
I know there is some strange things going on with Digital Confusion also. On my old G3 Mac it just crashed, I never got it working on it. But on my G4 it works prefectly (just need to turn of adaptive sampling)

So maybe Newteks mac programmers are using G4's and dont know about the G3 problems. In my opinion I think that Lightwave should work on G3's becaus Apple still sells ibooks that uses G3 processors.

05-17-2003, 09:39 AM
Hey... I'm on a g4 and it still crashes. I have no clue why, but it does. I thought Newtek had taken the 4-5 months and worked out all the problems? Hrmm... wonder what they were doing? Anyway.. back on normal 7.5 and all is working fine.

(edit) Anyone else having a Layout crash? My modeler works perfect, but layout is a diff story.

05-17-2003, 04:11 PM
I get the same error message as Aris with modeler:

Application Launch Failure

The application "(null)" could not be launched because of a shared library error:"#<Modeler><Modeler><lwtools3.shlb><>"

I'm driving a dual gig G4 with OS 10.2.6

I guess I'll have to reinstall Lightwave 7.0.

Someone isn't doing their job very well at Newtek.

05-18-2003, 06:54 PM
See my new post in this forum about how to install correctly, it might help.

05-18-2003, 08:59 PM
SeptemberSnow read your error message!
You could have more than one version of Lightwave on your machine, which is a huge no-no. Try to find out where the 'shared library' is. It could be that you haven't yet deleted the old Modeler app, the installer could have failed to remove it. Or it could be a library file error. Find the lwtools3.shlb, and see if there's any duplicates. If not, replace it. See if this helps.

As for me. Not one problem, installed it when it arrived and I haven't seen one problem.

Dual 1.25Ghz PowerMac G4
1GB Ram
ATi Radeon 64MB
Mac OS X 10.2.6


05-18-2003, 09:52 PM
So.... anyone here up for Lightwave 8?

05-19-2003, 12:37 PM
I get crashes both in modeler and layout using G4 powerbook running 10.2.6. I think it's still the open GL problem that apple never addressed. I was getting the same thing with 10.2.5 running Lightwave 7.5

05-19-2003, 03:06 PM
modeler not crashing at launch, but crashing regularly now since c.
.. getting annoyed..
- think that its open gl/ati prob, tho, cuz modeler was crashing now and then since upgrade to 10.2.5 but not as much as now.

05-20-2003, 12:20 AM
Well I'm having the same problem when running 7.5c on my ibook. Layout runs perfectly fine. But turn on modeler and pop. It has to be an issue with the g3. A few times the crash message contained the culprit problem. I switched it back to 7.5 for now.

on my Dual g4 both layout and modeler run sweet. So far.


05-21-2003, 01:23 PM
Well... not exactly on launch but with practically the first thing I do once I get in. :mad: :( :mad:

05-21-2003, 02:03 PM
Originally posted by Match-Boy
Well I'm having the same problem when running 7.5c on my ibook. Layout runs perfectly fine. But turn on modeler and pop. It has to be an issue with the g3. A few times the crash message contained the culprit problem. I switched it back to 7.5 for now.

on my Dual g4 both layout and modeler run sweet. So far.


I'm actually fairly confident this error has to do with 10.2.5/10.2.6 and the ATI video drivers, not LightWave, since the iBook has ATI Rage Mobility video HW.

05-21-2003, 02:11 PM
i disaggree now. Because I could manage the random freezes before c, now they are frequent to the point of having to reboot everytime I work in LW.

05-21-2003, 07:49 PM

I think you are on to the real culprit. After reading your post I remember that I was at the Apple store to get my new battery and while I waited they loaded me up with 10.2.6. My dual G4 only has 10.2. Plus layout was working fine after the install and I did work on it for hours. It was only after having to turn Modeler on did I realize the problem.

Hopefully the problem will be solved soon. I suggest a reinstall of 7.5 till they do.


05-21-2003, 08:49 PM
Trash prefs and see if that works?

06-16-2003, 01:50 PM
Same here with the instant modeler crash on 10.2.6. Layout seemed fine except for a slight OGL display problem in LightView and the fact that any model with a jpeg map caused a crash until I removed the JPEG.p.

Tech suggested going on a downgrade to 10.2.4 but seeing as every other app works fine for me in 10.2.6 I think I'll just leave old 7.5c well alone and head back for 7.5. Looks like Newtek have done it in their pants for Mac users yet again.

One strange thing I noticed in System Profile about LightWave 7b is that it gets listed as version 6.5 for Layout Modeler and Hub, 7.5 gets listed as version 7.5 for all three. Another bit of strangeness is the fact that in get info for both 7b and 7.5 there is the option to open in Classic and there are the old memory settings too although they are not resetable.:confused:

06-16-2003, 01:59 PM
I have removed all installations of 7.5c.

Before doing that, both Modeler & Layout launched (I wouldn't say worked) on my desktop: 2x800 G4, 1.2 GB RAM, nVidia GeForce 4MX (64 MB) 10.2.6

Modeler would not even launch (crash on startup) on my iBook: 600MHz G3, 640MB RAM, ATI Rage Mobility (8 MB), 10.2.6

06-17-2003, 12:28 PM
Hi Guys,

I've been running LW 7.5c modeler for a while now on a PowerMac G4 DP 1GHz (768MB) with ATI Radeon 9000 Pro (64MB) under Mac OS X.2.6 and haven't seen any crashes...

My grid disappears if I try to use plain wireframe, but other than that, I haven't had any Modeler display issues or crashes...

I'm sure this has probably been tried, but you can try a brand new clean install of 7.5 and then run the updater to 7.5c. That way you are sure to have a nice clean install.

Then if modeler still crashes, if you can provide some more details (steps if necessary) and machine specs, I can see if I can reproduce anything here, I have about 15 different Macs I can try some things on... If we can provide NewTek with some specific configurations that cause the crashes I'm sure they can get them fixed... or alert ATI and/or Apple if the problems are really within their domains...

Also, the person that posted the following error message...

The application "(null)" could not be launched because of a shared library error:"#<Modeler><Modeler><lwtools3.shlb><>"

Are you still getting that? I got that error message (and many variatons of it with crashes on launch etc) when trying to run multiple copies of LWSN over the network on the host machine which worked fine in Mac OS X.2.3. It turned out that in Mac OS X.2.6 I couldn't run more than five copies of LWSN over the network from the same machine.

It may not be a LW specific issue though, because I then used the chess program as a test and found I couldn't run the chess program across the network from the host machine if I was already running five copies of LWSN on the same host machine, chess would crash on load. Qutting some of the LWSN instances then let chess run over the network again... Perhaps there is some bug in Mac OS X.2.6 that prevents more than five processes to share the same library or some type of lock/permission error dealing with multiple accesses to shared components... just a guess...

Anyway, once I installed LWSN locally on all my remote nodes, that particular error message and launching crash disappeared...


06-17-2003, 12:54 PM

I have had modeler crashing issues with 7.5c. The machine that modeler crashes on is a PB G3 running OS 10.2.6 with just an 8mb video card. I think it maybe a problem with running 7.5c on a G3. I know the machine I had it installed on is by no means powerful enough, to run Lightwave at a decent working level, but I did run 7.5 without crashing problems. I never did have any problems using layout under 7.5c. Actually, I thought it was working great untill I tried to open modeler. I hope Newtek can get this worked out soon.


06-17-2003, 02:42 PM
I tried the completely clean install in as much as I could seeing as my 7.5 is an updater for 7b.

I get no problems with 7b then update no problem to 7.5 and both Layout and Modeler work with nothing more problematic than the usual flakiness with 7.5. Aim that 7.5c right on target at the 7.5 folder and again Layout seems to work except for crashing at jpegs, fixed that little glitch easily enough but Modeler still bottoms out before the interface shows up.

If 7b and 7.5 have no problems with OSX 10.2.6 there doesn't seem to be any acceptable reason for 7.5c to get buggered on it. Remember folks they pulled the mac 7.5b because it was a lemon and I'm not hearing much to suggest that 7.5c is any better.

7.5c is in the bin for me too.

06-17-2003, 03:42 PM
Well for s**ts and giggles, I installed LW on my "classic" box: an 8600 with a G3/450 processor upgrade, an ATI Nexus 128 video card, and OS 10.1.5. Modeler crashes on launch. Makes me wonder now if its a combination of ATI & G3 processors, since some folks have success with ATI & G4s... Oh, yeah, I mean 7.5c

06-17-2003, 03:48 PM
I'll try installing 7.5c on a few different older systems tonight with G3's and ATI boards to see what happens... though they are running MacOS 9.1... I'm currently only running Mac OS X.2.6 on our G4 PowerMacs and G4 PowerBook...


06-17-2003, 04:03 PM
It'll be interesting to see if old 9.1 can cope with 7.5c.
Keep us informed MikeS.:D

06-17-2003, 09:24 PM
I went home and tested two older systems to see if I could reproduce the 7.5c Modeler crashes... Sure enough...

PowerBook G3/233MHz "Wallstreet" with 288MB RAM, ATIRage (I think) System Profiler identifies it as "ATY,264LT-G", Mac OS 9.1

Power Macintosh 9500/132 with Newer G3/300MHz upgrade card in it, 368MB RAM, ATI Exclaim 3D video board as the main monitor and a 3Dfx Voodoo3 2000 video board driving a second monitor (primarily used for FA/18 Korea), Mac OS 9.1

I installed a fresh copy of LW7.5 on both machines and Layout and Modeler both ran fine.

I then installed the LW7.5c update on both machines and Layout launched OK but Modeler crashed on launch with a type 3 error on both systems...


06-18-2003, 05:26 AM
That makes for interesting reading MikeS, thanks for taking the time to run the tests. It looks like bad news unless you happen to have the right lucky combination of cards and processors and isn't just a problem with 10.2.6.

Newtek need to know about this.:(

06-18-2003, 10:06 AM
I'm keeping the dev team advised of the results here and we are also working with the Mac beta group on duplicating the results and trying to pinpoint the source.

06-18-2003, 10:34 AM
Good news the cavalry has just arrived!
That's a relief, thanks Chuck.:)

06-18-2003, 07:06 PM
Hope we see a 7.5cc soon. I don't imagine it is anything serious.

Crossing fingers while thinking I am hungry and I should eat.

06-19-2003, 02:43 AM
Something a little faster than 7.5cc would be nice.:p

06-19-2003, 04:20 AM

07-04-2003, 05:22 PM
Have you got any news for us yet Chuck?