View Full Version : Modeler v. 7.5 Zoom stops at 100 mm when I load my models

Julius Caesar
02-16-2003, 11:13 AM
Hello all,
I have a very annoying problem with my LW 7.5, but I had that one since LW 6.0. It was not there in 5.5...!
The problem is this one: I load my models (most of the time houses and other ancient buildings..) and the ZOOM (IN) stops to work. That is, it works but it does not want to go further than 100 mm. In other words, I cannot have details... The opposite (zoom out) works fine, I can arrive to several Kms...
One strange thing is that before loading my models, when the program is just started, it WORKS!! Only after the loading it stops.
As I already said, I have this very annoying problemssince LW 6.0 and earlier.
I use a 2.2 GHz Pentium IV with a Matrox Parhelia, bit I have this problem on other Matrox cards.. (I normally use Matrox cards for my PCs).
Anybody else had this problem and, if yes, how s/he solved this..?
Thank you very much for your time....

Julius Caesar

P.S. VBulletin is a powerful forum.. Thank for giving us such useful tool!!!!!!

:mad: :mad:

02-16-2003, 01:11 PM
Well this sounds very strange, iv just tested on mine and i can zoom all the way down to 0.1um which is i think the lowest mesurement posible in lw, and its much much lower than 100mm so i dont really know what could be wrong.


Julius Caesar
02-17-2003, 07:07 AM
Hello James,
thank you so much for having check with your LW...
That is really strange... I really would like to get rid of this very annoying limitation that seems to be related to MY computers... I say MY because I had a "old" 600 MHz with a Matrox G400 that I have upgraded with a new 2.2 GHz with a Matrox Parhelia. In the meantime, I have upgraded also my LW from 6.whatever to 7.5. Nothing! Same! Identical! When I start Modeler it Zooms properly but when I load/create an object it stops @ 100 mm. For me this is one of the most limitating problems I am having so far... I have some buildings where I need to create nice details and this prevent me to modify them properly (I can introduce non-planar polygons, I can miss details, etc)...
Please, could somebody from Newtek reveal some magic parameter to change in the Config files????
Thank you...

Almost Desesperate LW User

02-17-2003, 07:13 AM
Check your default units. If they are set to "kilometers" or something big, it could cause this. Set it to "meters" or something smaller.

02-17-2003, 04:32 PM

I have run across this problem occasionally. What I normally do is select a point then do 'shift a'. This usually solves the problem.

Hope this helps you!

Julius Caesar
02-17-2003, 05:05 PM
Mattclary and Stewpot,
thank you for your post. Unfortunately your suggestion did not resolve my problem, so I am starting to think that the problem is on my side. I have attached a file coming from my collections of Buildings... I would like to ask if it is possible to open it with another version of LW and check that if the zoom still works.
The outcome of this test will help me a lot to understand what is going wrong with this issue. I am starting to think that the "dimension" of the model limits the Zoom feature...
As "thanks" for your kind help, you can keep the model and use as you want. I know that is a "wonderful" model, but anyway....
I would like to thank you in advance for your precious help...


02-17-2003, 05:12 PM
Im checking it out now.
I'll get back to ya in 5 mins or so :)


02-17-2003, 05:18 PM
Now thart is damn strange. I open the object and its imposible to go lower than 100mm, i then coppied it and made a new object, zoomed it to 1um then pasted it, using the zoom button i zoomed in and out and it let me go back to 1um but once i let go of the zoom button then hit a to fit it was back to 100mm minimum.

This is really odd cos in all the time iv used lw iv never noticed anything like this before, and i must of gone down to smaller zooms than this before on large objects, i know i have.

In my ealier post i made a 1um*1um cube and hit a to fit as a test and it zoomed down to that fine so i really done get whats going on.

Maybe this needs reporting to newtek.


EDIT:PS: i couldn't find anything small enough in the object (under 100*100 mm) to try shift + a on, i did a shift + a on 1 point but the zoom still wouldn't go below 100mm.

Julius Caesar
02-18-2003, 01:17 AM
Dear SpankDaddy,
thank you so much for having taken the time to check with my model. I ***really*** appreciated that!!!!! And finally I have the confirmation that it is not related to my systems... It happens elsewhere.... It does behave exactly how you described... The zoom, way down to 1 um and the it stops @ 100 mm ..etc etc.
Now I would like to report this to Newtek, in order to have *at least* an official position (a bug? Fixed? When? Next release? SOON? Immediately??)...
Thank you again for your kind help and best regards

a little less desesperate than 2 days ago...

02-18-2003, 06:28 AM
Well i was massing around with it some more, i made a new object and was able to zoom to 0.1um, i then made a 100m*100m*100m cube and was still able to zoom to 0.1um, i then subdivided it 7 times making a 24576 poly cube and im still able to zoom to 0.1um, i then copy and paste the cube and move the copy off to the side so theres a small gap between them, hit a to fit and now i can only zoom to 5mm. copy both of those and move them down a bit and i can still zoom to 5mm and if i copy those 4 again i can still zoom to 5mm, that last copy/paste almost killed my pc so i didn't go any further :)

Strange eh :)


Elmar Moelzer
02-18-2003, 06:36 AM
This problem has been reported by me to NewTek when LW 6.0 arrived. I thas been confirmed meanwhile.
Hopefully they will be able to fix it.
It is AFAIK related to OpenGL and its limited Z- buffer.
The exact problem- description is:
The further you are away from 0.0.0 (the Coordinate- center)in the Coodinatersystem, the less you are able to Zoom in.
I really hope Newtek is able to solve the problem. It is annoying especially if you need to work precisely on larger architectural models. This problem did not exist in LW 5.6 and earlier.

02-18-2003, 06:49 AM
Yeh just tried that, i moved 500km away from 0,0,0 and was only able to zoom to 500mm :)

Tnx Elmar.


02-18-2003, 12:37 PM
This problem drove me bananas just a few days ago. Had an architectural model imported from max that I couldn't zoom in on.

A quick fix is to Center Data (f2)

Julius Caesar
02-18-2003, 01:02 PM
Ok..thanks to everybody....
Finally I have discovered that it is a bug! I was messing around with this problem since few months. I have also reinstalled LW a imprecised number of times... Well... I hope a fix will come out quickly... I really cat't stop to regret my old functional wonderful fast indisctructible LW 5.6!!!!



Julius Caesar
02-18-2003, 05:22 PM
Hello...it's me again...
I am messing around a little bit with LW and I have created a box of 15 m @ 8 km and in fact I can Zoom only to 1 m.

I have modeled a pretty important ancient roman town and I have houses, temples and other big buildings placed @ 100 m or even 200 m from the center of the grid. I have modeled the see that has an extension of several Kms and so on. For me, it is completely impractical to use this version of LW for my work.
I cannot use the workaround with F2 as every building is placed at a precise place on a archeological map, between other buildings, etc. I cannot use my old version of LW because it is not compatible with the new format of the files... and exporting/importing in different format is a complete mess. The bottom line is that I am stuck... I cannot continue with LW... in any case. Very sad.....


Adrian Lopez
02-19-2003, 05:50 PM
Here's a workaround for the problem:[list=1] Unselect everything ('/').
Place the mouse pointer over the location you'd like to zoom in on. Do this on two different viewports and write down the approximate X, Y and Z coordinates of that location.
Open the Numeric panel ('n').
Select the Move tool ('t').
Negate the coordinate values obtained in step 1, enter them into the Numeric panel and click on 'Apply' (be sure to hit the Enter key after typing in the last coordinate value, otherwise the objects will not move correctly).
Reposition your viewports so that they're approximately centered about the origin.
Zoom in on your object.
Manupulate your object.
Unselect everything.
Select the Move tool.
Enter the values obtained in step 1 onto the Numeric panel and click on 'Apply'.[/list=1]A better solution might be to write a "center relative" plugin that centers all objects relative to the center of a selected object or named part. In the meantime this technique will do just fine, although it's certainly very tedious.

Adrian Lopez
02-20-2003, 12:50 AM
I just tested the workaround on Julius Caesar's model. I'm able to zoom in as closely as 0.1 um on arbitrary parts of the model by aligning those parts with the origin, as described in the workaround.

I've found it a bit difficult to center the view around the origin just using the mouse (step 6), so what I do now is to set the selection mode to "Points", create a point at the origin using the Numeric panel, hit the 'A' key (to "fit selected"), and delete the point. The view is then perfectly centered about the origin, and you can zoom in right up to 0.1 um.

Julius Caesar
02-20-2003, 10:12 AM
Hello Adrian,
thank you for the tip...I think I will take sometime to create a short script plugin that will help me to use your procedure in one shot.
And, of course, when done I will post the script for the forum community.... Anyway, I hope that a real fix will come out soon....

Best regards and thank you very much


04-23-2006, 08:11 PM
I have the same problem time to time. I was searching for solutions online and found this thread... then i REALLY solved it by taking your moving to orgin idea a bit further.

select everything within your object, then press F2, or use the "center" command in "translate" in the "Modify" tab.

this will center your model around the origin. I think the reason why you aren't able to zoom in is because the objects are super far away from the origin. every time I have used this command since figuring that out, it WORKS!!