PDA

View Full Version : What's that ??? Keys becoming fractional ???



Dirk
02-13-2006, 01:50 PM
I'm working on a character animation for a game (for realtime). The scene becomes big, but now I notice I have fractional frames in the animation, and I can't get them OUT! I have an IK goal for a leg, and allthough frame slider says it's frame 3974, when I hit enter, it's frame 3973.9998! I don't know if the engine of my customer can chew this (I'll know tomorrow), but it makes working really unpleasent, and I cannot get them out with graph editor (snap to frame) or Keyframer - only by hand!

What is that???

evenflcw
02-13-2006, 02:35 PM
Wierd. There's another function in the Dope Sheet that will snap keys in fractional frames to whole frames - Quantize. Maybe try that?

If that doesn't work maybe upload the keyframe to let others have a lok at it and bug report it.

Wonderpup
02-13-2006, 04:14 PM
Hi Dirk,

I'm sure that there is a button somewhere that turns fractional frames on and off- is it possible you have activated this by mistake? A bit of a long shot but maybe worth a check.

JamesCurtis
02-13-2006, 04:34 PM
There is a button in LW layout to turn on and off fractional frames. It's under Peferences -> General Options, about 3/4 of the way down the panel. However, if you had created frames on the fractional frames while it was active, I don't think the Graph Editor will reflect that. Not, sure, so check it out.

Darn. Bryphi77, you posted right before me, while I was typing.

Dirk
02-13-2006, 05:07 PM
Nope, wasn't "fractional frames", it was turned of all the time. No luck with the dopesheet. And I did'nt stretch the motions. The only thing I did was to copy them with Keyframer (cycle/bake), to make some variations.

But anyway, it should be possible to get the frationals out with "snap" or "quantize" - but it isn't. And if I try to quantize them with keyframer, it breaks the animation! It's as if whole keyframes simply vanish...!

Rory_L
02-14-2006, 01:28 AM
Unless you have real-time IK in the game, it won`t matter a jot about the IK goal being fractional: when you bake the bone rotations all their keyframes will be non-fractional.

Usually, if you press `b` in the Graph Editor you`ll bake your selected graph to regular keyframes.

Good luck,

R

Dirk
02-14-2006, 02:20 AM
uffff, Dopesheet's quantize can fix it! I didn't select all keys yesterday (not used to the new scene editor). Anyway, this was scary, and makes it uncomfortable to work on long scenes (if it was keyframer who created the fractionals).

I would really like to know if this happens only to me or if it is a general problem. If somebody wants to try do this:

-start with an empty scene, add a null
-give it a keyframe at 3973.9998 (so "fractional frames" have to be turned on at first)
-turn "fractional frames" off - slider shows keyframe at 3974, but after turning "Fractional frames" on again, hitting enter at the keyframe shows 3973.9998.
-try to fix the keyframe with grapheditor ("snap to keys") or Keyframer ("Defractionalize")

philipsavage
02-14-2006, 01:36 PM
Just a thought, you can get unintended, fractional, keyframes by changing the frame rate in general options from the default 30fps during an animation.