PDA

View Full Version : Killing the CTRL-Fbuttons in OS-X for Lightwave...



Red_Oddity
05-15-2003, 07:15 AM
Finally found a workaround/hack to the CTRL-Fbutton crap that comes with the Keyboard prefernces pane that keeps f-ing with Lightwave (since lightwave pretty much uses every CTRL-key combination possible)

Here is a small tut (might need the Developer kit to be installed on your system) and offcourse i can't be help liable for any damage or lost wrok resulting out of putting this tut in practise :D


Go to System\Library\PreferencePanes\
Make a backup of the Keyboard.prefPane (or the files you are going to change inside the Package)
Right click on Keyboard.prefPane
Choose Show Package content
Go to Contents\Resources\English.lproj (or whatever country preferences you chose for your keyboard)
Make a backup of FunctionKeys.plist if you didn't backup the entire Keyboard.prefPane
Right click on FunctionKeys.plist
Choose Get Info
Change the Ownership & Permissions so the the Owner is you.
Close the info panel
Open FunctionKeys.plist (with the Property List Editor, you may need to install de Developer kit for this)
Open the Root Dictionary
Change the numbers from ActiveWindow, Dock, Menubar, Toolbar and UtilituWindow to 255
Save and close
Right click on FunctionKeys.plist again
Choose Get Info
Change the Ownership & Permissions back so the Owner is system again (not really necesary, but let's play it safe.)
Close all windows and packages
Open the System preferences
Open the Keyboard Preference pane
Open the Full Keyboard Access tab
Change the Press Controll popup to Letter keys or Custom keys and then back again to Function keys.

Right now the shortkeys should have become blank and thus not active those features anymore.

This offcourse works also for the Letter keys but you'll need to hack the MnemonicKeys.plist should you want to.

wapangy
05-15-2003, 09:01 PM
Thank you!
It works great.