PDA

View Full Version : Trouble with my aching bones



gary7
02-01-2006, 11:46 AM
I am animating a lobster claw. I have 4 bones in the IK rig. The 4th is a small bone which is a pointer bone to follow for the GOAL which is a null. I have rotational limits on all the ones except for the small bone and all have inverse kinematics assigned to all in the chain. Now here's the problem. When I move the null just a tad to animate the rig, the whole claw jumps to a severe location. I can continue moving the null back to where it was, but i want to know why it is doing it. I can do a work around and set the 4th small pointer bones motion option to an UNCHECKED "keep goal within reach". I can also take the heading rotational limits off of the 1st bone and the keep the "goal with in reach" on, but I cant have both.

I have done the right claw with no problems with identical setting to the left claw, but that left one is giving me fits. I really can work with the "keep goal within reach" unchecked but really want to know why its doing what its doing.

I hope ya'll can follow that.

Thanks

SplineGod
02-01-2006, 02:18 PM
Try just deleting the bones in the bad claw and then mirroring the bones over from the good one.

gary7
02-02-2006, 01:34 PM
I kind of did a work around on my issue. I set the heading on the bone that was giving me trouble to a Heading of -372 (min) -246 (max) The original bone was something like 7 max and -40 min. I think the bone must be rotated oddly by mistake, but Ill live with the odd setting.

Gary