PDA

View Full Version : lighting in viper problem



newyuppie
01-26-2006, 10:47 AM
i have a scene with at least 3 lights, 2 area lights and 1 spotlight.
when i f9 render it, it comes out perfect the way i want it. nevertheless, on my viper and my surface editor, the lighting is so dim that i can barely see anything. if i need to change texture, i must rerender all the times to see what changed.
does anybody know what's wrong?

JamesCurtis
01-26-2006, 02:32 PM
Make sure all lights are on and that you haven't set any of them to be ignored in a render.

Only other thing is how many lights are set to display in Opengl [setting in Display Panel]. If it's only set to 1 and your first light in the list is set at a low light brighness value may be an issue. Not sure on this one though.

newyuppie
01-29-2006, 07:36 PM
i have 8 lights in opengl display settings, thats not it...
i found that if i use a spotlight and not an area light it seems to be a little brighter but nevertheless very dark in general. i also have 2 other area lights, one below the floor and one to theback of the object..

UnCommonGrafx
01-30-2006, 05:48 AM
Sounds like you have low diffuse settings on your objects. You have shaders on your objects? Viper isn't going to show you all shader results.

Tip: turn most of those lights OFF for opengl; put one light in only for opengl, but turn its diffuse and specular attributes off. In the future, when ogl is more useable, this will not be a good idea. But today, for such lighting situations, this will work well.