PDA

View Full Version : OT: Need help, FireWire ports not communicating



Matt
01-14-2006, 02:48 PM
Hi all

This is now officially driving me nuts! I'm starting to feel like the guy who's just bought a bag of Revels and they're all coffee ones!

Off-topic, but I know some of you are pretty handy at PC trouble-shooting!

Short Version:

I'm having issues with the FireWire ports in my PC, they appear to be receiving power from the motherboard because they charge devices like my iPod Mini etc. but they just don't want to communicate, for example, my external hard drive doesn't show up in 'My Computer', neither will my ipod show up in iTunes.

Thing is, one of the ports used to work perfectly, and the other, well some of the time!

Longer Version!

Just to expand on the picture a little, I have the following spec' PC:


Motherboard:
Asus P4C800-E Deluxe (875P Northbridge with ICH5R Southbridge)

Processor:
Intel Pentium 4 3.4Ghz Retail 512k (478) 800 HT

RAM:
2048mb Dual Channel PC3200 Premium Kit OCZ (4x512)

Internal HD:
Western Digital SATA 80gb (Boot) 200GB (Storage)

External HD:
250GB LaCie 'Big Disk' Extreme (Triple Interface USB 2.0, FireWire 400 / 800)

DVD:
Pioneer DVR-107

Graphics Card:
Gainward Ultra 2600 GeForce6800 Ultra DDR3 256MB

Sound Card:
Terratec DMX6Fire 24/96

OS:
Windows XP Professional (Build 2600.xpsp_sp2_gdr.050301-1519: Service Pack 2)

PSU:
ATX Nexus NX5000 500W

Case:
CoolerMaster ATX WaveMaster


Okay with all that out of the way, let's move on!

I have 2 FireWire ports at the moment, one directly on the motherboard accessible from the rear of the case, and another on a USB 2.0 / FireWire daughterboard underneath a flap on the top of the case (which is horrible I might add!)

The USB 2.0 ports on the daughterboard work fine, no issues at all, so I'm assuming the board is okay.

I have two devices that I used to use with FireWire (in order to free up some of the USB 2.0 ports)


The LaCie external hard drive

My iPod Mini


The FireWire port at the back used to work perfectly well with either of the devices.

The FireWire port on the daughterboard used to work fine with the LaCie external hard drive, but only ever charged the iPod, it never communicated with it.

Recently I upgraded my PSU from an ATX Nexus 4090 400W to an ATX Nexus NX5000 500W, bascially because my computer would benefit from the extra juice!

After changing the thing over, which went perfectly well, no issues at all, that is when I noticed my FireWire ports stopped working, well it could have been before, but that's the only significant thing I've done to my PC recently.

Now either I've missed a connection somewhere, or done something in the wrong order or I've fried just the VIA FireWire chip with ESD. I did ground myself by touching something large, metal and earthed! (A nearby radiator!)

I'm pretty much ruling out ESD as everything else is working perfectly, frying one chip and not affecting anything else on the motherboard would be pretty slim! Have to say, I've never had a problem with ESD (touch wood, or, well, metal!)

I've also tried un-installing the IEEE 1394 Host Controller driver, then re-installing it again (it's currently using a VIA OHCI Compliant IEEE 1394 Host Controller by Microsoft v5.1.2535.0) and is reporting no problems in Device Manager.

I'd spoke to shop who built my PC about this a while ago (when I only had a problem with the daughterboard port not working with my iPod) and they sent me a new daughterboard to try, I've installed this one and it's still not working.

Basically I'm totally out of ideas! Anyone else have anything to try here? Any suggestions will be gratefully received!

Cheers
Matt

P.S. Sorry about the length of this, but I wanted to be thorough!

P.P.S. As a total cop-out workaround, I've just ordered a Belkin PCI USB 2.0 / FireWire 400 controller card. But I'd still like to get the other FireWire ports working if I can.

jeremyhardin
01-14-2006, 03:24 PM
i haven't worked on computers with daughterboard-related issues, so these are guesses.

given the info (which was very thorough btw), i'd guess the problem is:

1. bios or irq related.
2. jumper config error on the motherboard/daughterboard.
3. connector problem (bent pins/ dirty connections, etc).

how does the daughterboard connect to the motherboard? ribbon cable? maybe try replacing the ribbon cable.

Matt
01-14-2006, 04:33 PM
Thanks for the reply.

The daughterboard comes with the case, it has a MIC input, a Line Out jack, 2 x USB 2.0 and 1 x FireWire 400 ports on it.

Both the FireWire and USB 2.0 ports connect to the motherboard via separate leads. The USB2.0 ports work perfectly.

The FireWire doesn't, it just charges.

The FireWire port on the back of the computer that is soldered directly onto the motherboard used to work, but now only charges too, neither communicate with devices attached to them.

FireWire on the motherboard is controlled by the VIA VT6307 chipset.

Here's a picture of the daughterboard (not installed in the case at this point)

I'll gonna try updating the BIOS, although with my PC being just about a year old, no updates for the BIOS have appeared in a while!

I doubt whether it's the jumper settings as nothing has changed in swapping over the PSU.

Cables could have been damaged on the board, but I've tried another one and still have the same problems.

But that doesn't explain the port on the motherboard being damaged as it's not been touched!

jeremyhardin
01-14-2006, 04:41 PM
i dunno why the PSU would have changed it, but I've had problems with IRQ's in the past, particularly with onboard shiz. requesting conflicting IRQs causes malfunctions of some devices that are not necessarily going to just 'stop working' perse.

I had an onboard network card, which I disabled, but it was requesting the same IRQ as another device that I had installed (11) and I couldn't make my installed device accept a different IRQ because the IRQ's were locked to certain slots. Its all rather confusing still, but in the end I had to put certain cards in certain slots in a certain order because one of the devices could grab a different IRQ than default, but only if it's default was taken, whereas another device could only take a specific IRQ.

And you said the USB and Firewire connect via separate leads? perhaps the leads are faulty?

Silkrooster
01-14-2006, 05:33 PM
Did you look over the bios settings. It is possible that usb is enabled while firewire is disabled. Normally there is no setting for firewire, but since this came with the system, its possible. Same goes for a jumper. I think the cable can only be plugged in only one direction (double check that). Perhaps the daughter card is not seating good assuming the cables go to a isa card or is it the motherboard? Try getting a new firewire cable unless you have a multimeter to check continuity(another option to test cable is a flashlight bulb, some wire and a battery and make your own - If the light lights the cable is good, but make sure it only lights on one connector on each end of the cable.) A auto supply store may carry a continuity tester.
As for grounding, the radiator may not work if it is painted. What I do(which manufactures don't recommend) it leave the power cord plugged in, then the case is an excellent ground. However stick anything metal into the components and good buy system. Getting a shock is low, but possible. As you are dealing with low voltage. Unless you decide to stick something into the power supply(Very bad idea).
Hope this helps

jeremyhardin
01-15-2006, 11:07 AM
so i'm assuming (since you've also posted this on spinquad) that our advice didn't get you sorted?

Matt
01-15-2006, 11:27 AM
Nope still can't get it working.

It's definately enabled in the BIOS, there are no IRQ conflicts, Device Manager reports the controller is working.

Power is going to the ports because they charge the devices, they just don't make that next step to communicate with Windows.

I have two devices that use FireWire (and USB 2.0 fortunately) so unless both cables died at the same time, I doubt it's that.

So either it's a Windows issue, which is odd as changing the PSU does nothing to upset any settings like that, and the port on the back used to work fine.

So I guess that pretty much leaves the possibility that the IEEE 1394 controller chip got danaged somehow when changing the PSU over. The fact that nothing else is bust is very odd if that was the case though.

Run out of ideas, apart from a complete system rebuild. Which might not be a bad idea as I have a ton of crap from various installs / un-installs etc.

Matt

Mha8649
01-15-2006, 01:57 PM
The only thing I can think of is drivers.... The psu wouldnt have changed it unless you bumped something loose while changing it. I would check the irq's make sure theres no conflicts ...and then go into the device manager and select the firewire ports and see if it says theres any problems with the device.Well after noticing the previous post I guess you can disregard all this.

WeAreTheLeeches
01-16-2006, 02:10 AM
try looking under your network settings. i remember i had this problem when i was first setting up my pc. Your firewire ports are treated as network connections, i disabled mine bacause i wasnt sure what they were (they are called something like port 3334, but im not sure on that, i dont use pc's anymore!)

So open up network connections from our control panel and check that everything is enabled in there.

Matt
01-16-2006, 05:06 AM
Already looked at the network connections, interestingly, Windows won't let me disable any of them! Very odd.

However ... we have some developments guys, check this thread:

http://discussions.apple.com/thread...1535605#1535605

Cheers
Matt

jeremyhardin
01-16-2006, 09:42 AM
would love to, but that link has 3 dots in the middle that won't do me any good ;).

Matt
01-16-2006, 01:19 PM
Copy and paste seems to have gone tits up to! Try this now:

http://discussions.apple.com/thread.jspa?threadID=311267&tstart=0

Silkrooster
01-16-2006, 03:52 PM
Have you checked the irq settings making sure the ipod driver or firewire driver are not conflicting with anything?
I forgot all about network settings and yes you should beable to disable the fire wire from the network connections and its called 1394 (just correcting WeAreTheLeeches statement, you almost had it right. :D ).
Silk

Matt
01-16-2006, 04:54 PM
Yep, looked at all that, no IRQ conflicts, although what is odd is that Windows won't let me disable ANY of my network connections, let alone the 1394 one.

I'm to the point of taking a Glock to my temple now! :(

Silkrooster
01-16-2006, 06:34 PM
Hmmm. maybe a permission problem.
Silk

Mha8649
01-16-2006, 11:08 PM
The Glock ideal sounds good but misdirected aim it twords comp.
If you do decide to do a complete reinstall of system and it still doesnt work ... I would check into buying a new board. I have firewire ports but never had to use them so Im sorry I couldnt be more helpful.

habaņero
01-20-2006, 05:58 PM
Do you have a windows restore point from when it worked? You can revert the process.

Have you checked your voltages when running the computer? If it is overvolting, you could possibly fry components. Or make them hotter, which could make them inable to run at the speed they will have to. A really long shot is bad (high or uneven) current coming into the house, this stuff does happen from time to time though and can mean all electronic equipment in the house get an early pension. I really don't think this is the case at all, but I would just like to mention that it can be a thing to check if you get "strange" problems on your hardware like several parts dying in different computers. Bad grounding also sounds possible, I had two computers here running the one on grounded and the other on what I just thougth was grounded and so I noticed from getting mild shock when touching both. Fortunately didn't touch anything inside the case at the time ...

It'd be interesting to know if there is any messages in the administrative tools -> event viewer, mayby at startup or when inserting a disk in the FW. I've had similar trouble to what you describe with network connections, those can be bitches in XP and so it could very well both be related to your problem or not.

You could try clearing cmos and setting the values in bios up again/flashing in the same bios again. My fathers new computer not see the harddrives after my brother had messed with some incompatible trimming tools and that was the fix.

****edit: think I maybe found it!


Found this (http://www.techsupportforum.com/asus/7705-got-working-asus-p4c800x-series.html) off gougle, might be some bios settings there to try.

And:

eccc
Registered User



Join Date: Jan 2005
Posts: 2
OS: WinXP


P4C800-E Deluxe USB-Problems
This is my second ASUS board that screwed up :(
Though I'm not sure it's the mobo this time.

PROBLEM: The Plug And Play does not work in windows. My computer does not detect the hardware installed by PnP even if the USB-Port power works just fine. this is with all the USB ports. Does anyone have the same problem as me or atleast know what it could be? please help me :)


01-18-2005, 01:04 PM #2
mark3567



Posts: n/a
OS:


Hi,

There are two things you might double check. First of all, go to the BIOS setup menu and Turn PnP to DISABLED if you are using WinXP. That way the Bios configures instead of the OS. Be sure you save before you exit. Second, go to the Device manager and update all your drivers in the USB area. If you have WinXP, then you should not have to put a disk in since most reside within the windows OS, but if it asks for a disk, put in what it asks for.

A side note, You did remember to load your chipset drivers when you built your computer, didn't you?

link (http://www.techsupportforum.com/asus/34729-p4c800-e-deluxe-usb-problems.html)

Seems your not the only one with these problems, I think probably ignore the advice I put on top of my post but I'll leave it since it could be relevant to similar problems anyway.

**** edit 2: I just stumbled over an issue today that affects some asus computers. It is a tiny bit complicated but if you have OST brand capacitators on your board they could be the culprit. There's a guide to indentifying this at badcaps.net (http://www.badcaps.net/). Could fit.

Matt
01-30-2006, 01:28 PM
Managed to finally sort this out, check the thread on Apple's forum I've posted:

http://discussions.apple.com/message.jspa?messageID=1637961

Still need to send off my LaCie drive to be fixed though!

Matt