PDA

View Full Version : Ugly bad renders



lt_ethe
05-11-2003, 04:31 PM
I'm getting some real bad renders on a scene file of mine. The first picture is the default renderer. The second picture has raytracing turned on. Not only does it get progressively more ugly, but notice how in the ratraced scene, the volumetric lights have disappeared as well.

Anybody have any ideas what's up?

lt_ethe
05-11-2003, 04:32 PM
Raytraced pic.

Aegis
05-11-2003, 07:07 PM
Dude, have you heard of anti-aliasing? :D

1. OK, seriously - turn anti-aliasing on at say, "Enhanced Medium" - that'll make the image much smoother.

2. All those shiny surfaces could do with something to reflect - either apply a reflection map or put your object in a scene.

3. LightWave's "default" render is seldom used for anything except quick render tests - Either enable raytracing or use shadow-mapped spotlights otherwise your renders will look somewhat strange (lights will shine clean through solid faces) which brings me to...

4. Your volumetric lights may well have disappeared in the raytraced render 'cause they have a polygon blocking them - you need to make sure nothing is obstructing them.

Nice model though - you have one strange imagination! ;)

lt_ethe
05-11-2003, 11:30 PM
I gave all your suggestions a whirl just in case. No dice. It's not the anti-aliasing I'm worried about it's:

A) The really ugly green/yellow colors I'm getting in the raytraced render.
B) the wack blue color I'm getting in the default (phong I assume) render
C) The loss of volumetric lights in a raytraced render.

Please note, that except for the big blue chunk at the bottom, the first pic (non raytraced) is actually accurate. I'm still working through the model for my own viewing purposes, so I'm not interested in anti-aliasing as of yet.

Mylenium
05-11-2003, 11:37 PM
For me it definitely looks like you forgot to turn on raytraced reflections, refractions and transparencies. This would cause this ugly coloring errors in raytrace mode if you use .e.g. gradients with incidence angle. And yes, the volumetric light seems to be obstructed by some piece of your mesh (You may always turn of its shadows, though).

Mylenium

lt_ethe
05-12-2003, 12:16 AM
Raytraced reflections, shadows, transparencies, all of dose checkboxes... And enhanced medium anti-aliasing turned on here.

Granted, this is a prettier version of ugly, but it's still pretty ugly. I qazuple checked the v-lights as well... They're unobstructed by anything, still no show to the raytrace party.

lt_ethe
05-12-2003, 12:30 AM
Mylenium has hit the problem on the head though, if not the apparent solution. All of the troublesome shaders are because of gradients with incidence angle.

So i think we've got a fair handle on the problem now, thanks all. I'm still taking submissions for solutions.

Turning off shadows on the v-lights did help indeed for the raytraced renders, so many thanks to Mylenium.

Thanks for all your help so far all.

lt_ethe
05-12-2003, 12:44 AM
Raytraced reflections, shadows, transparencies, all of dose checkboxes... And enhanced medium anti-aliasing turned on here.

Granted, this is a prettier version of ugly, but it's still pretty ugly. I qazuple checked the v-lights as well... They're unobstructed by anything, still no show to the raytrace party.

mattclary
05-12-2003, 11:24 AM
Would you care to post a copy of the scene and objects?

Rei
05-12-2003, 11:47 AM
I have had a problem with V-lights when Ray tracing, it makes them very low power. Try putting up the power, and the size too.

Elmar Moelzer
05-13-2003, 12:12 AM
Volumetric lights wil show in refelcting surfaces too, make sure you dont forget about that.
CU
Elmar