PDA

View Full Version : Screamernet not working OSX



mattshort
11-24-2005, 01:14 PM
I'm trying to set up a renderfarm. I used the WOA tutorial to set it up. The Screamer Init doesn't recognize any CPUs and when I try to launch LWSN it says it can't open job file "". I followed the tutorial step by step. Anybody get this to work?
Computers are:
G4 Dual 1.42 OSX.4.3
G4 Powerbook 1.2 OSX.4.3
G4 450 OS9.2.2
Also, now when I try to load the scene I was going to render, none of the effects are there. I get the message "No plug-in of type CustomObjHandler found with name FX_Emitter. Would you like to load it from disk?" This is for all the Hypervoxels I painstakingly added to the scene. How do I get this back? Where on the disk is it?

brayne
11-28-2005, 12:28 AM
Hi Matt,

It's been some days since you posted your problem, and I hope LightWave hasn't been out of commission all this time. If I understand your post, you have been unsuccessful in setting up ScreamerNet, and have messed up your LightWave preferences in the process.

The WOA tutorial encourages the altering of command line files to move the default location of your preferences. Although there is plenty of logic in doing this, I don't actually recommend it as I think it's too easy to make a mistake.

You will need to re-establish the location of your plug-ins. I'm assuming you are using LightWave 8.x. Go to the Utilities tab, and then select the Edit Plug-ins button. From the Edit Plug-ins window, click the Clear button. It will ask for confirmation. Click OK. Now click the Scan Directory button. Navigate your way to the LightWave application folder, and then into the Plug-ins folder which is contained within. Click Choose, and Lightwave should scan the plug-ins folder, and then report on how many Plug-ins it has found. Click OK and then click the Done button to close the Edit Plug-ins window.

Now you must quit LightWave to store these new preferences. Next time you launch, your plug-ins should be found, and your hypervoxels should be fine.

Once all is well with that, let me know, and I will help you with a quick and easy way to set up ScreamerNet (and don't worry, I'm not just going to try and sell you my software!)

eblu
11-29-2005, 08:39 AM
but I will.
Bruce makes screamernet bearable with renderfarm commander. Its easy, it works, and Bruce is very approachable.

We use it at my work. And without renderfarm commander, we'd have no render farm. Screamernet is too volatile, too cranky, and too difficult to setup and maintain to be worth messing with. Render farm Commander takes control and brings screamernet kicking and screaming into the realm of useful.

Thomas
11-30-2005, 01:22 AM
but I will.
Bruce makes screamernet bearable with renderfarm commander.

Well, and I'll go a bit further then :D

RenderFarm Commander makes Screamernet awesome! No fiddling, no setup. Push the buttons, load a scene, render, done!

Buy it, can't go wrong with it!

Hhm, but I did once and Bruce helped me out. Awesome support!


Regards
Thomas

brayne
12-01-2005, 11:31 PM
Thanks guys!

I think I'm going to have to start paying a commission to some of the people on this forum! :)

Bruce

mattshort
12-12-2005, 02:53 PM
Hi Matt,

I'm assuming you are using LightWave 8.x.

I'm actually using 7.5. Will this work and can I use other computers running OS9.2? I cleared and replaced the plug-ins.

brayne
12-12-2005, 03:19 PM
I'm actually using 7.5. Will this work and can I use other computers running OS9.2?

Hi Matt,

Yes, RenderFarm Commander works with 7.5 (I still use 7.5 myself), however the latest version has stopped supporting OS9. This is with very good reason though. Due to the way OS9 handles memory, it is usually the cause of constant problems in a render farm. My suggestion is to load OSX onto these computers, even if you only boot into OSX when you are rendering. I would recommend probably 10.2.8. It's very stable with render farms and not as big as some of the newer systems. Feel free to boot into OS 9 all other times.

How did you go with your plug-ins?

Bruce

mattshort
12-13-2005, 02:59 AM
How did you go with your plug-ins?

Bruce

I opened the Edit Plug-ins window (through the Layout tab) and followed your instructions. After restarting Lightwave, the scene with hypervoxels was restored. Also, I have OSX installed on the computer with OS9.

brayne
12-13-2005, 04:31 AM
I opened the Edit Plug-ins window (through the Layout tab) and followed your instructions. After restarting Lightwave, the scene with hypervoxels was restored. Also, I have OSX installed on the computer with OS9.
Excellent. I will try and put together a short tutorial movie to help you set up your render farm.